Closed Bug 542431 Opened 12 years ago Closed 12 years ago

crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] (windows), [@ @0x0 | thunderbird-bin@0x9ac340] and [@ @0x0 | thunderbird-bin@0xa99167] [@ thunderbird-bin@0xa99167] (Mac)

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 531568

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash, qawanted)

Crash Data

crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)]
from crash-stats

not in 3.0.1 top 300, but there may be other tops of stack.

bp-3e0db209-f195-48ec-80f1-ccc222100105
while moving folders to other account 
0  	thunderbird.exe  	nsMsgCopyService::ClearRequest  	 mailnews/base/src/nsMsgCopyService.cpp:210
1 	thunderbird.exe 	nsMsgCopyService::DoNextCopy 	mailnews/base/src/nsMsgCopyService.cpp:335
2 	thunderbird.exe 	nsMsgCopyService::DoCopy 	mailnews/base/src/nsMsgCopyService.cpp:263
3 	thunderbird.exe 	nsMsgCopyService::CopyFolders 	mailnews/base/src/nsMsgCopyService.cpp:571
4 	xpcom_core.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
Mac variations appear to be 

@0x0 | thunderbird-bin@0xa99167  v3.1
bp-e7419a02-d3e9-4bc3-bb29-ce86f2100805
0		@0x0	
1	thunderbird-bin	thunderbird-bin@0xa99167	
2	thunderbird-bin	nsMsgCopyService::ClearRequest	mailnews/base/src/nsMsgCopyService.cpp:100
3	thunderbird-bin	nsMsgCopyService::NotifyCompletion	mailnews/base/src/nsMsgCopyService.cpp:681
4	thunderbird-bin	nsImapMailFolder::OnCopyCompleted	mailnews/imap/src/nsImapMailFolder.cpp:7992
5	thunderbird-bin	nsImapMailFolder::OnStopRunningUrl	mailnews/imap/src/nsImapMailFolder.cpp:5292
6	thunderbird-bin	nsMsgMailNewsUrl::SetUrlState	mailnews/base/util/nsMsgMailNewsUrl.cpp:136
7	thunderbird-bin	nsImapMailFolder::SetUrlState	mailnews/imap/src/nsImapMailFolder.cpp:6640 


@0x0 | thunderbird-bin@0x9ac340 v3.0.6
bp-77fbb4c9-74f8-4eef-981c-14d772100804
0		@0x0	
1	thunderbird-bin	thunderbird-bin@0x9ac340	
2	thunderbird-bin	nsMsgCopyService::ClearRequest	mailnews/base/src/nsMsgCopyService.cpp:216
3	thunderbird-bin	nsMsgCopyService::NotifyCompletion	mailnews/base/src/nsMsgCopyService.cpp:664
4	thunderbird-bin	nsImapMailFolder::OnCopyCompleted	mailnews/imap/src/nsImapMailFolder.cpp:7957
5	thunderbird-bin	nsImapMailFolder::OnStopRunningUrl	mailnews/imap/src/nsImapMailFolder.cpp:5253
6	thunderbird-bin	nsMsgMailNewsUrl::SetUrlState	mailnews/base/util/nsMsgMailNewsUrl.cpp:135
7	thunderbird-bin	nsImapMailFolder::SetUrlState	mailnews/imap/src/nsImapMailFolder.cpp:6606 


unsure if nsASDOMWindowEnumerator::GetNext(nsISupports**) bp-134db3b0-7c43-4f7f-85d3-701092100804 fits in at all
Component: Networking → Networking: IMAP
OS: Windows Vista → All
QA Contact: networking → networking.imap
Summary: crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] → crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] (windows), [@ @0x0 | thunderbird-bin@0x9ac340] and [@ @0x0 | thunderbird-bin@0xa99167] (Mac)
I missed Mac crash thunderbird-bin@0xa99167 bp-95c652f7-231b-402d-8333-6555a2100804 v3.1.1
Summary: crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] (windows), [@ @0x0 | thunderbird-bin@0x9ac340] and [@ @0x0 | thunderbird-bin@0xa99167] (Mac) → crash [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] (windows), [@ @0x0 | thunderbird-bin@0x9ac340] and [@ @0x0 | thunderbird-bin@0xa99167] [@ thunderbird-bin@0xa99167] (Mac)
related to Bug 471492?  and bug 548424 a duplicate?
Keywords: qawanted
Bug 548424 looks like a DUP, the car just crashed into a slightly different wall on a Mac.  Maybe related to Bug 471492, but only insofar as something's going wrong with the "copy" function for IMAP folders (fixing Bug 471492 MAY fix this, but that's not a given).
Duplicate of this bug: 548424
I doubt bug 471492 is related
Depends on: 535125
I think this is a dup of bug 531568
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531568
Crash Signature: [@ nsMsgCopyService::ClearRequest(nsCopyRequest*, unsigned int)] [@ @0x0 | thunderbird-bin@0x9ac340] [@ @0x0 | thunderbird-bin@0xa99167] [@ thunderbird-bin@0xa99167]
You need to log in before you can comment on or make changes to this bug.