Clicking open on download pop-up dialog on maemo.org opens microb instead of app manager

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Fennec 1.1
ARM
Maemo

Details

(URL)

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.1)
Gecko/20100126 Firefox/3.6.1 Fennec/1.0.0

Steps to Reproduce:
1. Go to http://maemo.org/downloads/product/Maemo5/conversations
2. Click on "Install"
3. In the downloads pop-up dialog, click on open

Actual Results:
microb is opened with the contents of the file

Expected Results:
The app manager should be opened and begin installation of the program. When clicking on open with http://ftp.mozilla.org//pub/mozilla.org/mobile/candidates/1.0rc3-candidates/repos/1.9.2_multi the application manager opened and installed the catalog.
(Reporter)

Comment 1

8 years ago
When clicking on "Save" and oepning from the downloads manager, the application manager opens and the program is installed.
(Reporter)

Comment 2

8 years ago
The url has been updated with the correct page to go to

Comment 3

8 years ago
Something that works:

host-4-95:~ dougt$ curl http://ftp.mozilla.org/pub/mozilla.org/mobile/mozilla-fennec.install -I
HTTP/1.1 200 OK
Date: Wed, 27 Jan 2010 16:58:30 GMT
Server: Apache/2.2.3 (Red Hat)
Last-Modified: Thu, 16 Oct 2008 17:55:24 GMT
ETag: "8964d4-f7-8d971b00"
Accept-Ranges: bytes
Content-Length: 247
Connection: close
Content-Type: application/x-install-instructions




something that doesn't:


host-4-95:~ dougt$ curl http://maemo.org/downloads/product/raw/Maemo5/conversations-inbox-widget/?get_installfile -I
HTTP/1.1 200 OK
Date: Wed, 27 Jan 2010 17:07:39 GMT
Server: Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny4 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g Midgard/8.09.7
X-Powered-By: Midgard/8.09.7
X-MidCOM-meta-cache: HIT R-e857795d761a104da04fc6b33afdf7cf
X-MidCOM-meta-cache: HIT C-416df8fa097d8f1a165c40ff303ca082
X-MidCOM-data-cache: HIT C-416df8fa097d8f1a165c40ff303ca082
Expires: Wed, 27 Jan 2010 17:03:31 GMT
Cache-Control: max-age=0 must-revalidate
Pragma: no-cache
Content-Disposition: attachment; filename="conversations-inbox-widget.install"
Content-Length: 197
ETag: 416df8fa097d8f1a165c40ff303ca082
Accept-Ranges: none
Last-Modified: Wed, 27 Jan 2010 16:59:30 GMT
Vary: Accept-Encoding
Content-Type: text/html; charset=utf-


The content type on maemo.org isn't being sent.
(Reporter)

Updated

8 years ago
tracking-fennec: ? → ---

Comment 4

8 years ago
rather -- 

The content type on maemo.org is being sent as text/html with a content disposition of an attachment.  Fennec happily downloads this file but because Fennec isn't the registered handler of text/html files, we ask the system "who handles text/html".  It sounds like MicroB still has that registration.

A server side solution would be to ask maemo.org to send a content type of "application/x-install-instructions".

I would still like to better understand what it means to be the default handler of text/html on the device.




This can be tracked in a new bug if you like.

Comment 5

8 years ago
this has been fixed on maemo.org
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Duplicate of this bug: 532672
(Reporter)

Comment 7

8 years ago
verified FIXED on build:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.2pre) Gecko/20100216 Namoroka/3.6.2pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.