Last Comment Bug 542686 - Block YSlow v. 2.0.5 for Fx 3.5 and 3.6
: Block YSlow v. 2.0.5 for Fx 3.5 and 3.6
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Mac OS X
: -- blocker (vote)
: ---
Assigned To: Michael Morgan [:morgamic]
:
: Jorge Villalobos [:jorgev]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-27 17:32 PST by Damon Sicore (:damons)
Modified: 2016-03-07 15:30 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Damon Sicore (:damons) 2010-01-27 17:32:24 PST
Need to block version 2.0.5 of this addon:

https://addons.mozilla.org/en-US/firefox/addon/5369

Version 2.0.5 has caused a massive spike in multiple crashes, currently 2.4% of all crashes are caused by this addon.  Need to block it immediately.

Please call me if there are any questions.
Comment 1 Michael Morgan [:morgamic] 2010-01-27 17:34:51 PST
Going to just hard block yslow 2.0.5 for Firefox versions > 3.5.7.
Comment 2 Michael Morgan [:morgamic] 2010-01-27 17:49:35 PST
Are we blocking everything below 2.0.5 too or just that version specifically?
Comment 3 Michael Morgan [:morgamic] 2010-01-27 17:50:34 PST
I'll block 2.0.5 for now and expand it later if we need to.
Comment 4 Michael Morgan [:morgamic] 2010-01-27 17:52:12 PST
Resulting blocklist XML:
    <emItem id="yslow@yahoo-inc.com">
      <versionRange minVersion=" 2.0.5" maxVersion="2.0.5">
        <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
           <versionRange minVersion="3.5.7" maxVersion="*"/>
        </targetApplication>
      </versionRange>
    </emItem>

Query:
INSERT INTO `blitems` (`guid`, `min`, `max`) 
VALUES ('yslow@yahoo-inc.com', '2.0.5', '2.0.5');
INSERT INTO `blapps` (`blitem_id`, `guid`, `min`, `max`) VALUES ((SELECT MAX(id) FROM blitems), '{ec8030f7-c20a-464f-9b0e-13a3a9e97384}', '3.5.7', '*');
Comment 5 Michael Morgan [:morgamic] 2010-01-27 18:05:49 PST
This was run and is in production now:
https://addons.mozilla.org/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.0b1/?omgpeanuts

I'll push the mozilla.com blocklist info.
Comment 6 Justin Scott [:fligtar] 2010-01-27 18:06:55 PST
Did we tell the YSlow team we were doing this?
Comment 7 Michael Morgan [:morgamic] 2010-01-27 18:21:19 PST
It's a known issue.  Mike, Mike or Damon can answer about outreach though.
Comment 8 Justin Scott [:fligtar] 2010-01-27 18:35:21 PST
Yeah, I know it's a known issue, and have been on the email thread with the developers about it. I'm wondering if there is another thread where we discussed this with them, since it wasn't on the one I'm on.
Comment 9 Michael Morgan [:morgamic] 2010-01-27 18:46:35 PST
Yeah, I know you know it's a known issue and I'm pretty sure they talked to them about it.
Comment 10 Michael Morgan [:morgamic] 2010-01-27 18:58:19 PST
Mike/Damon -- did we let them know, or is this just your decision from a Firefox perspective?
Comment 11 Mike Shaver (:shaver -- probably not reading bugmail closely) 2010-01-27 19:00:09 PST
(Might need to call him, per comment 0.)
Comment 12 Fred Wenzel [:wenzel] 2010-01-28 02:54:37 PST
(In reply to comment #4)
>       <versionRange minVersion=" 2.0.5" maxVersion="2.0.5">

Is the space in the minVersion attribute harmful?
Comment 13 Fred Wenzel [:wenzel] 2010-01-28 02:57:17 PST
Ah, it's auto-generated. Nevermind.
Comment 14 Michael Morgan [:morgamic] 2010-01-28 09:56:28 PST
Shouldn't be there -- will take a look.

Note You need to log in before you can comment on or make changes to this bug.