[mozmill] Remove attendees not working in Event modification test

RESOLVED FIXED in 7.0

Status

defect
RESOLVED FIXED
10 years ago
3 months ago

People

(Reporter: merike, Assigned: Taraman)

Tracking

(Blocks 1 bug)

unspecified
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

10 years ago
Event modification test from bug 535812 fails on Mac per bug 535812#c7. Needs investigation if this is Mozmill only or a bug in Lightning.
OS: Mac OS X → All

Comment 1

8 years ago
testing
Assignee

Comment 2

7 months ago
Meanwhile, the test is repaired.
Only thing is that the attendees are failing the test when changed, so they are excluded at tho moment.

I believe it is the way they are set in testing is the reason (I can't make the context menu work and have to work around by deleting attendees via JS directly).

So I change the Summary to reflect the new situation and have a look at it.
Assignee: nobody → Mozilla
Summary: Unnecessary prompt to save with no changes in Mozmill test → [mozmill] Remove attendees not working in Event modification test
Assignee

Updated

7 months ago
Blocks: 983787
Assignee

Comment 3

4 months ago
Posted patch eventMod.diff (obsolete) — Splinter Review

I finally figured out, that a link to the attendee Object has to be added to the Menulist.
Noramally this is done on rightclick, but for some reason it isn't when being opened by mozmill. So we do this manually.

Now the Test works as intended.

Try-Run:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=f2ef5125e28871050416bac638604ec2b07c1bf9

Attachment #9048298 - Flags: review?(geoff)

That's weird. Is the object set when not in a test? Is it just a case of waiting for it?

I'd rather not hack a test together like that if we don't have to.

Assignee

Comment 5

4 months ago

When rightclicking "manually", everything works fine.

in the test I tried everything from clicking the entry beforehand, to waiting and every combination of calling the menu I could think of.

For some reason, in the Test it just doesn't work.
Finally, I found no other solution than this hack. :-(

The last thing I can think of is to try to add some logging code to lightning-item-iframe.js to try to find out what is missing when in a test...

In lightning-item-iframe.xul, change the onclick attribute to oncontextmenu, and it works properly. Apparently the rightClick function doesn't send a click event with button = 2.

Assignee

Comment 7

4 months ago

Fascinating!

Shall I add that change in this Bug?

Yes.

Assignee

Comment 9

3 months ago
Posted patch Fix V2Splinter Review
Attachment #9048298 - Attachment is obsolete: true
Attachment #9048298 - Flags: review?(geoff)
Attachment #9052737 - Flags: review?(geoff)
Comment on attachment 9052737 [details] [diff] [review]
Fix V2

Review of attachment 9052737 [details] [diff] [review]:
-----------------------------------------------------------------

Nice one.
Attachment #9052737 - Flags: review?(geoff) → review+

Pre-emptively setting checkin-needed, as the Try run is still going.

Keywords: checkin-needed

Comment 13

3 months ago

Pushed by Mozilla@Adrario.de:
https://hg.mozilla.org/comm-central/rev/fc995375f444
[mozmill] Remove attendees not working in Event modification test. r=darktrojan

Status: NEW → RESOLVED
Closed: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 7.0
You need to log in before you can comment on or make changes to this bug.