Right click menu entries "Open Link in New Window" and "Open Link in New Tab" should be switched

RESOLVED DUPLICATE of bug 322736

Status

()

Firefox
Menus
--
enhancement
RESOLVED DUPLICATE of bug 322736
8 years ago
8 years ago

People

(Reporter: mlissner@michaeljaylissner.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2pre) Gecko/20100128 Ubuntu/9.10 (karmic) Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2pre) Gecko/20100128 Ubuntu/9.10 (karmic) Firefox/3.5.2

This is a usability request, and more opinions on whether this would be an improvement are welcome. 

My main way of opening links in new tabs is to right-click a link and then use the "Open Link in New Tab" menu item. Every once in a while, I will want to open a tab in a new window, and to do that, I'll use the "Open Link in New Window" menu entry. 

I just started experimenting with Google Chrome, and they have put "Open Link in a New Tab" first, and "Open Link in a New Window" second. This seems to make sense to me, and I think Firefox should make this change. I've very quickly gotten used to this ordering, and I can tell that it's saving me time already.

I suggest that Firefox should make this change as well.

I evaluated the Epiphany and Konqueror menus, and they didn't provide any standard that should be followed: Epiphany doesn't include an "Open in New Tab" entry (huh?), and Konqueror's menu is a mess.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322736
You need to log in before you can comment on or make changes to this bug.