Search Messages dialog closes when Enter is hit, rather than starting search

VERIFIED FIXED in seamonkey2.1a1

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: rsx11m, Assigned: InvisibleSmiley)

Tracking

({regression})

Trunk
seamonkey2.1a1
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
I'm usually concluding a search term with the Enter key to get the search started, to save a mouse click. This works in SM 2.0.2 but not in the 2.1a1pre nightlies, where the search dialog is just aborted. This happens on both IMAP and Local Folders, but the error console only seems to report an error on an IMAP folder search, and only if it is currently open. [Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100129 SeaMonkey/2.1a1pre]
 
Steps to reproduce:
1) Right-click on a folder and select "Search Messages";
2) Enter any search string and finish with the Enter key;
3) Search window unexpectedly closes.

Expected behavior: Should start the search.

Error Console says (not always): Error: document is null
Source File: chrome://messenger/content/mailWindow.js
Line: 364
(Reporter)

Comment 1

7 years ago
Identical symptoms for Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20100201 SeaMonkey/2.1a1pre, using a fresh profile.
OS: Windows XP → All
Hardware: x86 → All
Summary: Search window closes when Enter is hit, rather than starting search → Search Messages dialog closes when Enter is hit, rather than starting search

Comment 2

7 years ago
Same bug on Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.3a4pre) Gecko/20100402 Mnenhy/0.8.0pre15 SeaMonkey/2.1a1pre.
(Assignee)

Comment 3

7 years ago
Created attachment 436682 [details] [diff] [review]
fix error and problem

The actual problem was caused by bug 515228 (conversion from window to dialog).
The document is null error is unrelated but let's fix it while we're here.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #436682 - Flags: review?(mnyromyr)
(Reporter)

Updated

7 years ago
Blocks: 515228

Comment 4

7 years ago
(In reply to comment #3)

> Created an attachment (id=436682) [details]

WFM

Comment 5

7 years ago
Comment on attachment 436682 [details] [diff] [review]
fix error and problem

>+      if (!document) return;
This is just wallpaper, and it's unclear that it's necessary once the underlying bug is fixed.

>+        defaultButton="search-button"
defaultButton is a btntype, not an id.
(Assignee)

Comment 6

7 years ago
Created attachment 436769 [details] [diff] [review]
patch v2

(In reply to comment #5)
> (From update of attachment 436682 [details] [diff] [review])
> >+      if (!document) return;
> This is just wallpaper, and it's unclear that it's necessary once the
> underlying bug is fixed.

Well, it won't hurt either, right?

> >+        defaultButton="search-button"
> defaultButton is a btntype, not an id.

Hmm, right (dlgtype, actually). I'm a bit confused that it still worked in a way but I agree that my approach was wrong. The new one should be cleaner since it disables the window.close() code path in dialog.xml's _doButtonCommand method that triggered the problem (_fireButtonEvent calls onbuttonaccept).
Attachment #436682 - Attachment is obsolete: true
Attachment #436769 - Flags: review?(mnyromyr)
Attachment #436682 - Flags: review?(mnyromyr)

Comment 7

7 years ago
Comment on attachment 436769 [details] [diff] [review]
patch v2

>diff --git a/suite/mailnews/mailWindow.js b/suite/mailnews/mailWindow.js
>   ensureStatusFields : function()
>     {
>-      if (!this.statusTextFld ) this.statusTextFld = document.getElementById("statusText");
>+      if (!document) return;

This is (a) unneeded with your fix below and (b) not really a fix anyway, just like Neil already said - please drop it.
No need to touch the whitespace in that vicinity then either.

I do get another warning, though, when searching (IMAP):
  JavaScript strict warning: chrome://messenger/content/mailWindow.js, line 487: reference to undefined property window.MsgStatusFeedback
=> Seems to be old, filed bug 563484 on that.

>diff --git a/suite/mailnews/search/SearchDialog.xul b/suite/mailnews/search/SearchDialog.xul
>         ondialoghelp="return openHelp('search_messages');"
>+        ondialogaccept="return false;"

Maybe it's worth having a short inline comment here, like /* allow Search on Enter */.

r/moa=me with that.
Attachment #436769 - Flags: superreview+
Attachment #436769 - Flags: review?(mnyromyr)
Attachment #436769 - Flags: review+
(Assignee)

Comment 8

7 years ago
Created attachment 443215 [details] [diff] [review]
patch v3 [Checkin: comment 9]
Attachment #436769 - Attachment is obsolete: true
Attachment #443215 - Flags: superreview+
Attachment #443215 - Flags: review+
(Assignee)

Comment 9

7 years ago
Comment on attachment 443215 [details] [diff] [review]
patch v3 [Checkin: comment 9]

http://hg.mozilla.org/comm-central/rev/ed24c9dfc66b
Attachment #443215 - Attachment description: patch v3 → patch v3 [Checkin: comment 9]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
(Reporter)

Comment 10

7 years ago
Verified fixed Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100504 SeaMonkey/2.1a1pre nightly build, thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.