Moved occurrences of repeating all-day events are displayed on new and original date

RESOLVED FIXED in 1.0b2

Status

Calendar
Provider: Local Storage
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: A. Sel., Assigned: Fallen)

Tracking

Lightning 1.0b1
1.0b2
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

When creating a recurring whole-time / full-time event and moving one instance of this event by drag & drop in the calendar view (multiple weeks) to another day, the event for this day will have been duplicated after restarting thunderbird, so that the event exists on both days (the original, the day it was moved to). 

Deleting one of the events will sometimes delete both (may depend on which of both you delete).

The recurring events (f. ex. this event next month) are not effected.

Reproducible: Always

Steps to Reproduce:
1. Create a recurring full-time event
2. Drag one instance of it to another day
3. Restart Thunderbird
Actual Results:  
Dragged event exists on both days

Expected Results:  
Dragged event only exists on the day it was dragged to
(Reporter)

Updated

8 years ago
Component: General → Calendar Views
Version: unspecified → Lightning 1.0b1

Comment 1

8 years ago
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8pre) Gecko/20100202 Calendar/1.0b2pre. 

Seems to be specific to all-day events and storage provider because I can't reproduce it using ics provider.
Status: UNCONFIRMED → NEW
Component: Calendar Views → Provider: Local Storage
Ever confirmed: true
Flags: blocking-calendar1.0?
QA Contact: general → storage-provider
Summary: A moved recurring event has been duplicated after restart → Moved occurrences of repeating all-day events are displayed on new and original date
(Assignee)

Comment 2

8 years ago
Created attachment 431606 [details] [diff] [review]
Fix - v1

Stupid mistake I made while fixing bug 468846. Just passing a numeric parameter doesn't make it pass by reference! This is the much cleaner fix anyway.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #431606 - Flags: review?(ssitter)
(Assignee)

Updated

8 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+

Comment 3

8 years ago
Comment on attachment 431606 [details] [diff] [review]
Fix - v1

r=ssitter
Patch works, but only for new created events. What should happen to occurrences that were created with Sunbird 1.0b1 and that are stored without the proper flag in the database?
Attachment #431606 - Flags: review?(ssitter) → review+
(Assignee)

Comment 4

8 years ago
Unfortunately there's not much we can do about that. We had the same problem in bug 468846 itself. We don't really know if the exception is really an allday exception or not, so we can't update flags. 

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/188b04a3f384>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.