Closed Bug 543844 Opened 10 years ago Closed 10 years ago

Breakpad should produce stack traces for x86_64 minidumps

Categories

(Toolkit :: Crash Reporting, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jimb, Assigned: jimb)

References

Details

+++ This bug was initially created as a clone of Bug #543843 +++

At the moment, the Breakpad processor x86_64 stack walker is a stub: it only gives you the top stack frame.  Doing full backtraces on the x86_64 requires the DWARF CFI support in bug 464750, and some additional work to hook the CFI stuff into the x86_64 stack walker.

The SimpleCFIWalker is supposed to be something that many architectures can use to get CFI-driven stack walking going quickly; you give it a map of the relevant registers and it does the rest.
Assignee: nobody → jim
Status: NEW → ASSIGNED
Blocks: 547474
Duplicate of this bug: 547474
No longer blocks: 547474
For the record: the x86_64 breakpad client (minidump writer) works, but is not enabled by default --- it being not very useful without the stack walker.  Once we have landed the stack walker, we just need to flip a switch in the build machinery.
End-to-end tests passed; submitted stack walker to Google for review.

http://breakpad.appspot.com/66001/show
Patch approved by Google.
Patches landed upstream.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.