Closed Bug 543856 Opened 11 years ago Closed 10 years ago

Jetpack dependencies on Firefox/Gecko bugs

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chofmann, Unassigned)

References

Details

(Whiteboard: [platform-2010Q1])

tracking for things needed 1.9.3 and maybe beyond.
Depends on: 532569
Depends on: 537838, 542428
Depends on: 545227
Depends on: 533845
Note: in some cases we even want these things for 1.9.2, if they can be safely backported, like bug 533845, whose patch has a pending approval1.9.2.2 request.
No longer depends on: 545227
Depends on: 545227
Morphing title to reflect dependencies on both Firefox and Gecko bugs, moving to the new JpSecure component that's tracking reboot work.
Component: Jetpack → JpSecure
OS: Mac OS X → All
QA Contact: jetpack → jpsecure
Hardware: x86 → All
Summary: jetpack dependencies on core gecko bugs → Jetpack dependencies on Firefox/Gecko bugs
Depends on: 542385
Adding most bugs that are tagged [jetpack].  I left off the menu bugs, since it's unclear whether the reboot will support menus in the same way as the prototype.  Also left the [jetpack] whiteboard on those bugs.
Depends on: cpow, 524771, 525249, 526010, 102699
cc:ing Damon so he's aware of changes to this list of bugs.
It might help us prioritize specific bugs if we knew which Jetpack issues are hard blockers.  We have a goal this quarter to make sure we fix any Jetpack platform blockers, and knowing which ones block will help make that happen.  Thoughts on how to mark them?
Whiteboard: [platform-2010Q1]
Several bugs here are marked blocking1.9.3=beta1 (bug 532569, bug 533845, bug 537838, bug 542385, bug 542428).  IIRC it was suggested in the Platform meeting two or three weeks ago to request blocking on Jetpack blockers.  Would that work?

Atul, are these bugs and their blocking statuses up to date for your needs?
Depends on: 546678
The following bugs are no longer dependencies on Jetpack--that is,
they can actually be removed as dependencies from bug 543856:

  bug 524771 and bug 525249 are actually no longer even definite
    dependencies for Jetpack; the security approach we're taking no
    longer relies on these bugs.

  bug 545227 is no longer a dependency; our new approach in actually
    integrating the Jetpack platform into Firefox itself to make
    Jetpack-based extensions 100% secure, means that extensions don't
    need to support signed bootloaders.

The following are dependencies on bug 543856 that actually constitute
"hard blockers" for Jetpack:

  bug 542428 and bug 537838 are hard blockers, required for our
    current security approach.

  bug 542385 is required for no-restart.

  bug 546678 might as well be a hard blocker, as integrating Jetpack's
    test suite into Firefox and Thunderbird's will save us a
    ridiculous amount of downstream integration work.

  bug 516522 is a hard blocker for electrolysis integration only; if
    electrolysis isn't actually considered a 'blocker' for the
    platform, then this bug shouldn't be a blocker either.

All other bugs that are currently marked as dependencies for bug 543856 can
be considered soft blockers.
What I'm seeing, is cpow is really the only bug that is controlled by platform devs.  Is that correct?
ok, removed   bug 524771 and bug 525249 and bug 545227
No longer depends on: 524771, 525249, 545227
Damon: bug 532569 is also a hard blocker of our ability to incorporate content iframe-secured extension widgets into Firefox browser chrome windows with correct styling.  Fortunately, roc has a patch for that, and it has review/superreview, so it is only awaiting landing (and he thinks the patch is low-risk enough to land on 1.9.2 after the appropriate baking on the trunk).
Depends on: 553102
Bug 546678 isn't a Firefox/Gecko bug (it's a task on which the Jetpack and RelEng teams will collaborate), so removing it from this list.
No longer depends on: 546678
Is this meta bug still being used? There are no bugs that it's currently blocking.
No, we're no longer using it.  resolved -> fixed

This was a bug to track platform dependencies that the platform team was working on for the Jetpack team in the first quarter of this year, and the absolute blockers have been resolved.

I'm now collecting dependencies on this wiki page:

  https://wiki.mozilla.org/Labs/Jetpack/Dependencies

I've moved the two unresolved dependencies from this bug to that page.

If other folks think it'd be useful, y'all're welcome to reopen this bug and continue to use it to track these dependencies.

For me, the problem is just that meta-bugs like this don't provide readily-accessible context for each of the bugs on the dependency tree, which makes it hard to track them.  I find the wiki page, where I can describe each bug, the reason it's on the list, and its current status right next to the bug reference, more helpful.
No longer depends on: 102699, 553102
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.