If I cancel Weave's master password dialog, it re-prompts me (and the second dialog triggers a warning icon/message if I complete it)

RESOLVED DUPLICATE of bug 530697

Status

()

RESOLVED DUPLICATE of bug 530697
9 years ago
27 days ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

9 years ago
(sorry, pressed 'enter' instead of 'tab' in bug summary field, which submmitted bug before I could fill out the description)

STEPS TO REPRODUCE:
 0. Configure a firefox profile with a Master Password. Install Weave & configure it with an account.
 1. Restart Firefox
 2. Allow ~5 seconds for Weave to init. Then, click Weave icon in status bar, and choose "Connect"
 3. Cancel the resulting master password dialog.

EXPECTED RESULTS:
No more dialogs should appear.

ACTUAL RESULTS:
A second master password dialog appears.  If I cancel it, then everything's fine (except that it shouldn't have been there in the first place).  BUT if I type in my master password and press "OK", I get an orange triangular exclamation-point icon in the Weave Status Bar, with this error message when I click on it:
>  Error While Signing In
>  Weave encountered an unknown error while signing you in:
>  Unknown error. Please try again.
Summary: If I cancel Weave's master password dialog, it re-prompts me. → If I cancel Weave's master password dialog, it re-prompts me (and the second dialog triggers an error if I complete it)
(Reporter)

Comment 2

9 years ago
VERSION INFO:
Weave Sync 1.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100203 Minefield/3.7a1pre

Here's the verbose log, from Firefox startup to the latter chunk of ACTUAL RESULTS:
010-02-03 13:47:17	Service.Main         INFO	Loading Weave 1.0 in 5 sec.
2010-02-03 13:47:22	Engine.Bookmarks     DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.Forms         DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.History       DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.Passwords     DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.Prefs         DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.Tabs          DEBUG	Engine initialized
2010-02-03 13:47:22	Engine.Tabs          DEBUG	Resetting tabs last sync time
2010-02-03 13:47:22	Service.Main         INFO	Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100203 Minefield/3.7a1pre
2010-02-03 13:47:22	Service.Main         DEBUG	Caching URLs under storage user base: https://sj-weave06.services.mozilla.com/1.0/dholbert_test/
2010-02-03 13:47:22	Service.Main         DEBUG	Autoconnect failed: master password still locked; retry in 79 sec.
2010-02-03 13:47:40	Service.Main         DEBUG	Exception: User canceled master password entry Stack trace: anonymous()@crypto-SDR.js:193 < <file:unknown> < anonymous()@storage-mozStorage.js:1052 < anonymous()@storage-mozStorage.js:693 < <file:unknown> < anonymous()@nsLoginManager.js:522 < <file:unknown> < _logins()@identity.js:123 < password()@identity.js:87 < password()@service.js:130 < anonymous()@service.js:708 < WrappedNotify()@util.js:114 < WrappedLock()@util.js:86 < WrappedCatch()@util.js:65 < WeaveSvc_login()@service.js:692 < anonymous()@sync.js:278

NOTE: If I wait a minute or so after getting the orange exclamation-point icon described in "ACTUAL RESULTS", then Weave will automatically reattempt login (in the background) and will succeed, making the warning icon go away.
(Reporter)

Updated

9 years ago
Summary: If I cancel Weave's master password dialog, it re-prompts me (and the second dialog triggers an error if I complete it) → If I cancel Weave's master password dialog, it re-prompts me (and the second dialog triggers a warning icon/message if I complete it)
C'mon dude, at least search your _own_ bugs. ;)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530697
(Reporter)

Comment 4

9 years ago
d'oh... I did, but I failed because "Weave" wasn't in the summary. :)

Oops.
(Assignee)

Updated

27 days ago
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.