If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Create redirect for "plugin-crashed" help-topic

VERIFIED FIXED in 1.5.1

Status

support.mozilla.org
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: cilias, Assigned: laura)

Tracking

unspecified
1.5.1
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
We need the help-topic "plugin-crashed" to redirect to the article:
Plugin+crash+reports?style_mode=inproduct

For further info see bugs 538910 and 542410.

For QA:
Right now, we've got a placeholder that redirects to the "Firefox crashes" article, so that's were you should end up for now.
(Reporter)

Updated

8 years ago
Target Milestone: --- → 1.5.2
Blocks: 542410
(Assignee)

Updated

8 years ago
Assignee: nobody → laura
Don't forget to add an &as=u parameter to the query string to the rewrite to keep track of article hits coming from the UI.
Any chance we could get this done today? I'm planning on landing the patches that implement this today, so the link will be in tomorrow's trunk nightly.
(Reporter)

Comment 3

8 years ago
Don't let this hold you back. We're still waiting for QA to sign off on SUMO 1.5.1 before we can schedule a push to production. And this is a SUMO 1.5.2 bug (filed after 1.5.1 froze).

Updated

8 years ago
Blocks: 545893
The browser UI has landed and is live, and of course now we're getting reports that it's "broken" because this redirect is missing.

This shouldn't block on Sumo 1.5.2, the comment in bug 542410 indicates that this is a trivial 1-line htaccess change. Soon we'll be shipping a Firefox alpha with this link is a high-visibility UI which makes it even more important to get this working.

Comment 5

8 years ago
Laura, can we do a separate push to get this out asap?
(Assignee)

Comment 6

8 years ago
Aiming to push 1.5.1 Thursday, I'll get it in ASAP.
Target Milestone: 1.5.2 → 1.5.1

Comment 7

8 years ago
Thanks Laura!
(Assignee)

Comment 8

8 years ago
Created attachment 427189 [details] [diff] [review]
Add a rule
Attachment #427189 - Flags: review?(james)
(Assignee)

Comment 9

8 years ago
Oho, I forgot the EU ballot changes.  revised patch on the way.
(Assignee)

Comment 10

8 years ago
Created attachment 427194 [details] [diff] [review]
with eu stuff this time
Attachment #427189 - Attachment is obsolete: true
Attachment #427194 - Flags: review?(james)
Attachment #427189 - Flags: review?(james)
Comment on attachment 427194 [details] [diff] [review]
with eu stuff this time

The patch failed 2/2 on a clean checkout of the 1.5.1_temp branch. Does it depend on having the Weave patch applied first? If so, feel free to re-request after that's landed.
Attachment #427194 - Flags: review?(james) → review-
After applying all the patches that had already been applied to trunk, this still failed 1/2, the second hunk.
(Assignee)

Comment 13

8 years ago
It depends on the Weave patch and the as=u patch and was diffed against updated trunk.  I'll see if I can work out what the problem is, it's a two line patch so it can't be that hard.
(Assignee)

Comment 14

8 years ago
jsocol: applying this patch still wfm on trunk and branch, clean checkout of r62529.  Can you try again?
Comment on attachment 427194 [details] [diff] [review]
with eu stuff this time

After all the other commits, patch finally applied.

And it works for me.
Attachment #427194 - Flags: review- → review+
(Assignee)

Comment 16

8 years ago
In r62534/r62535
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-litmus?
Verified, FIXED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

8 years ago
Justin, 1.5.1 has pushed. The link from trunk builds should point people to the "Firefox crashes" article.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.