thunderbird is using 900MB of memory

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Noah McNallie, Unassigned)

Tracking

({perf})

1.9.1 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 3.5.7

Don't really know.. I have two email addresses configured for imap using google's mail servers. I was looking for another process in task manager and noticed firebird using 900MB of memory

Reproducible: Didn't try

Steps to Reproduce:
1. Assumingly just run thunderbird ?
2.
3.
Actual Results:  
Thunderbird used 900MB of memory

Expected Results:  
To use perhaps 32-64MB of memory
(Reporter)

Comment 1

8 years ago
correction this is *thunderbird* not 'firebord' (hehe) and it's version 3.0.1

Comment 2

8 years ago
please run through https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems and report results
Severity: normal → major
Version: unspecified → 3.0

Comment 3

8 years ago
I had a similar issue.

I have 2 x IMAP account connections totalling 100+ folders and my entire email archive is around 5GB.

Just over 2 weeks ago TB3 started to use huge amount of RAM and CPU power. At its worst, it was up to 1.5GB of RAM after just a few minutes of being started.

I disabled global indexing and searching, restarted and ever since I've had no issues. Average memory usage is now between 60-80MB of RAM.

Comment 4

8 years ago
Hi Nick. We're still waiting for Noah, but let's start on your issue.  If you haven't already, please please run through all the steps of 
https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems and report
results. If you find the only thing that helps is turning off indexing, please get a msgdb log.
Keywords: perf

Updated

8 years ago
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Version: 3.0 → 1.9.1 Branch
(Reporter)

Comment 5

8 years ago
I have been unable to reproduce the problem.

Comment 6

8 years ago
Noah in comment #5
> I have been unable to reproduce the problem

In that case, let's close this WORKSFORME.  If you see the problem in the future, please reopen the bug with detailshttps://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems from 

Nick, you'll want to file a new bug with detailshttps://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.