Closed Bug 544713 Opened 11 years ago Closed 9 years ago

Update the binutils version used for maemo builds

Categories

(Release Engineering :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: jrmuizel, Assigned: joduinn)

References

Details

(Whiteboard: [puppet])

No description provided.
The version of gas that we use has a bug that causes miscompilation: see bug 544697.
Whiteboard: [puppet]
is this something that we can fakeroot apt-get upgrade in scratchbox or do we need to build our own binutils?
Jeff,

is this still desired?  which version of binutils do you need?  Is it in the maemo.org repository?
Yes, this is still desired.

The version of gas that I have doesn't have the problem, and apparently 2.19 doesn't have the problem. I believe scratchbox should have a newer version but I'm not certain. What version do we currently have?
[sbox-CHINOOK-ARMEL-2007: ~] > dpkg -s binutils
Package: binutils
Status: install ok installed
Priority: standard
Section: devel
Installed-Size: 6644
Maintainer: James Troup <james@nocrew.org>
Architecture: armel
Version: 2.16.91cs2005q3.2-5.osso1
Provides: elf-binutils
Depends: libc6 (>= 2.3.5-1)
Suggests: binutils-doc (= 2.16.91cs2005q3.2-5.osso1)
Conflicts: gas, elf-binutils, modutils (<< 2.4.19-1)
Description: The GNU assembler, linker and binary utilities
 The programs in this package are used to assemble, link and manipulate
 binary and object files.  They may be used in conjunction with a compiler
 and various libraries to build programs.
We've lived without this for awhile, seems like it's not urgent.
Priority: -- → P5
Jeff: is this still required? Kinda embarrassed that this has sat this long.
Assignee: nobody → coop
OS: Mac OS X → Linux
Priority: P5 → P3
Assignee: coop → joduinn
Maemo -> tier 3.
Blocks: maemo-tier3
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.