Thunderbird is eating more and more space on my hard drive

RESOLVED DUPLICATE of bug 546384

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 546384
8 years ago
8 years ago

People

(Reporter: Dominique De Vito, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

I use Thunderbird v3.
It's a regular use, while I rebuild from time to time my inbox index (1 time every week) when Thunderbird losts the association subject/mail (that is, I rebuild this index, when, if I click on a message in my inbox with a given subject, Thunderbird gives a wrong mail, i.e. not corresponding the selected subject).

Reproducible: Always

Actual Results:  
my ImapMail directory (on my hard drive) is around 5 Go and keep growing and growing, while my inbox has not grown at the same speed.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
(Reporter)

Comment 1

8 years ago
Created attachment 425768 [details]
the Thunderbird directory growing and growing
(Reporter)

Comment 2

8 years ago
Created attachment 425769 [details]
the current size of the growing directory eating more and more space
Are you using exchange as a mail server ?

Does it stops growing when you switch off indexing (Tools -> Options ->Advanced tick out the global indexer)

Comment 4

8 years ago
(dupe of bug 314294 ?)

You can remove the nstmp* files. There should be normally be at most 1, the extra ones are made because the old one (nstmp) could not be removed for some reason, so a number was added to make a unique filename. I don't think there exists a mechanism to remove all of them.

The files are temporary files used when compacting folders. Apparently, this process is failing every time for you ? maybe bug 471077.
(Reporter)

Comment 5

8 years ago
@Jo Hermans

It sounds like https://bugzilla.mozilla.org/show_bug.cgi?id=471077 or *very* close - while I am not sure it's exactly the same case...

I meet the following situation twice within the last minutes (today):
- I delete a msg into my inbox: it's marked as deleted
- I compact my inbox
- a new file nstmp is created.
Bug 538610 due to Bug 532323? 
> Bug 538610 IMAP mailbox: infinite loop of "compacting folder..." (IMAP folder larger than 4GB limit of offline-store size)
> Bug 532323 4 GB limit of IMAP offline-store breaks sync of gmail "All Mail" and other systems
(Reporter)

Comment 7

8 years ago
@Ludovic

I don't think I am using exchange as a mail server, but I am not sure.

No, it doesn't stop growing when I switch off indexing (Tools -> Options ->Advanced tick out the global indexer)
(Reporter)

Comment 8

8 years ago
@Ludovic

Exchange is not used with my ThunderBird v3 instance.
Dominique, can you answer Wada's question about the size of your mailbox ?

Do you have any idea if condstore is enabled on your mail erver ?
(Reporter)

Comment 10

8 years ago
@Ludovic, 

Sorry, I missed Wada's question.

When I right-click on my inbox to see the quota displayed by Thunderbird, I could see the following: "32644 over 102400 Ko are used"

So, I use 32 Mo, not that much.

Hum, I have no idea if condstore is enabled on my mail server...

But according to my help desk support, no other user has risen the pb I face, because the other users respect the company's norm, that is, they use Thunderbird v2. So, it sounds like a Thunderbird v3 bug.

Comment 11

8 years ago
(In reply to comment #1)
> Created an attachment (id=425768) [details]
> the Thunderbird directory growing and growing

Hello Dominique, I didn't find your report when I made mine
https://bugzilla.mozilla.org/show_bug.cgi?id=546384
but I found it now. Yours and mine have one thing in common - we use IMAP. I wonder how you compress the folder - through the menu item, or through the button on the toolbar, or something different?
Tilman
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> (In reply to comment #1)
> > Created an attachment (id=425768) [details] [details]
> > the Thunderbird directory growing and growing
> Hello Dominique, I didn't find your report when I made mine
> https://bugzilla.mozilla.org/show_bug.cgi?id=546384
> but I found it now. Yours and mine have one thing in common - we use IMAP. I
> wonder how you compress the folder - through the menu item, or through the
> button on the toolbar, or something different?
> Tilman

Hello Tilman,
I compress the folder while selecting it, and right-clicking in order to choose the menu item "compact" ("compress" may be ? Well, I use a French Thunderbird version... so, I don't know exactly the words used into the English one).
I hope this helps.
Dominique

Comment 13

8 years ago
Hello Dominique,
This produces the same effect for me.
Please try this: 
1) Open Windows explorer and remember the highest nstmp file in your directory
2) Delete a message in thunderbird
3) Compress NOT from the context menu, BUT from the file (= "Fichier" for you) menu, the item has a text like "comprimer tout les fichiers", it is just below the rename menu item
4) Press F5 in the Windows Explorer and look what the highest nstmp file is now. 
I suspect that it did *not* increase. (or that it is deleted a few seconds later, when the compressions are finished)
If yes, then it means we have definitively the same bug :-) And some bugzilla expert should "join" the two, if possible.
Tilman

Updated

8 years ago
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Version: 3.0 → 1.9.1 Branch
(Reporter)

Comment 14

8 years ago
Hello Tilman,

(In reply to comment #13)
> Hello Dominique,
> This produces the same effect for me.
> Please try this: 
> 1) Open Windows explorer and remember the highest nstmp file in your directory
> 2) Delete a message in thunderbird
> 3) Compress NOT from the context menu, BUT from the file (= "Fichier" for you)
> menu, the item has a text like "comprimer tout les fichiers", it is just below
> the rename menu item
> 4) Press F5 in the Windows Explorer and look what the highest nstmp file is
> now. 
> I suspect that it did *not* increase. (or that it is deleted a few seconds
> later, when the compressions are finished)

You suspected cleverly and very well ;-)

Indeed, I followed your points 1-4 and no new nstmp-xxx file has appeared.

While, with the other way, if I select the "compact/compress" menu item after right-clicking on the "inbox" folder, a nstmp-xxx file is created (I have just checked today).

> If yes, then it means we have definitively the same bug :-) And some bugzilla
> expert should "join" the two, if possible.

So, if I understand correctly, we have the same bug.

Dominique

> Tilman

Comment 15

8 years ago
assuming bug 546384 isn't fundamentally related to Bug 539389 ... duping
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546384
You need to log in before you can comment on or make changes to this bug.