update-packaging broken with MOZ_PKG_PRETTYNAMES when MOZ_APP_DISPLAYNAME != MOZ_APP_NAME

RESOLVED DUPLICATE of bug 540833

Status

defect
RESOLVED DUPLICATE of bug 540833
9 years ago
a year ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Trunk
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

This used to work fine but broke sometime between the 3.6a1 and the 3.7a1 builds. MOZ_PKG_DIR is set to MOZ_APP_DISPLAYNAME for release builds (whereas it's normally set to MOZ_APP_NAME). For alphas, MOZ_APP_DISPLAYNAME gets changed to a code name. When the update-packaging target tried to run for 3.7a1, we had this error:
mkdir -p ../../dist/update/mac/en-US/
MAR=/builds/slave/macosx_build/build/obj-firefox/ppc/dist/host/bin/mar \
	  /builds/slave/macosx_build/build/tools/update-packaging/make_full_update.sh \
	  "../../dist/update/mac/en-US//mozilladeveloperpreview-3.7a1.complete.mar" \
	  "../../dist/universal/MozillaDeveloperPreview/MozillaDeveloperPreview.app"
/builds/slave/macosx_build/build/tools/update-packaging/make_full_update.sh: line 42: pushd: ../../dist/universal/MozillaDeveloperPreview/MozillaDeveloperPreview.app: No such file or directory
make: *** [complete-patch] Error 1

*But*, in dist/universal/firefox we had a MozillaDeveloperPreview.app. So it seems like at some point 'make package' started putting the package in a dir based on MOZ_APP_NAME rather than MOZ_APP_DISPLAYNAME.

The workaround used was to switch MOZ_APP_DISPLAYNAME with MOZ_PKG_DIR in tools/update-packaging/Makefile.in
Oooh this seems very similar to Bug 540833. Actually I'd say its so similar I think its a dupe.
Sounds right. Not sure how I missed that bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540833

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.