FireFox doesn't render <OPTION> elements' label attribute

RESOLVED DUPLICATE of bug 40545

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 40545
9 years ago
9 years ago

People

(Reporter: Axel, Unassigned)

Tracking

1.9.2 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

According to W3C HTML 4.0 Specs, "When rendering a menu choice, user agents should use the value of the label attribute of the OPTION element as the choice. If this attribute is not specified, user agents should use the contents of the OPTION element."

However, Firefox does not render the content of the label attribute.

Reproducible: Always

Steps to Reproduce:
<html>

<body>

<form>

<select>
  <optgroup label="test2">
    <option label="label1"/>
    <option label="label2">content2</option>
  </optgroup>
</select>

</form>

</body>
</html>
Actual Results:  
Firefox does not render the content of the <OPTION> elements' label attribute.

Expected Results:  
Firefox should render the content of the <OPTION> elements' label attribute, if present.
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → 1.9.2 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 40545
(Reporter)

Comment 2

9 years ago
Strange... I wasn't able to find the other one...
It happens.  Don't worry about it.  :)
You need to log in before you can comment on or make changes to this bug.