Closed Bug 545392 Opened 10 years ago Closed 10 years ago

Add preference for using date and time of download as last modified date (how it worked until 3.6.x) [replace problem]

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [use https://addons.mozilla.org/en-US/firefox/addon/93121 to get the old behavior])

Bug 178506 implemented the last modified date sent by the server to be set as last modified date in the file system. The recommendations are to enable the creation time in the file manager to see or sort the download times.

This doesn't work if you replace a file on download. It will have the last modified time from the server as modified time and the time of the first download as creation time.

Another example where the change breaks behavior: If you have folder with documents which you modify and sort by last modified to see the currently used documents and download a file from your predecessor out of the web-based intranet, you will have to search where it is in your list.

So please add add a preference for configuring this and consider to make the download time the default setting because it's more understandable for the user - how much of the users are interested in the modification date on a server?
Blocks: 178506
No longer depends on: 178506
Blocks: 178506
(In reply to comment #0)
> So please add add a preference for configuring this and consider to make the
> download time the default setting because it's more understandable for the user
> - how much of the users are interested in the modification date on a server?

The time stamp from the server is the only time that matters to me. Download time has no relevance to anything I do or use. Server stamp can tell me if the file I already downloaded is older than the one on the server. When it's not, I rarely want to download it again. When it is, I normally want the changed version, as I expect newer to mean updated and/or improved over the last version. Also when I sort, I often sort by age. Download time has nothing to do with real age. Download time should not be default.
I agree completely with comment #1.
Even if there is such a preference, it should be new behaviour be default. Comment #1 says it all. It's the way most of other apps do, and so shall Firefox.
(In reply to comment #0)
> This doesn't work if you replace a file on download. It will have the last
> modified time from the server as modified time and the time of the first
> download as creation time.
Edge case, really.  I'd be happy with a new bug that makes us not set the last modified time if we are replacing a file though.

> Another example where the change breaks behavior: If you have folder with
> documents which you modify and sort by last modified to see the currently used
> documents and download a file from your predecessor out of the web-based
> intranet, you will have to search where it is in your list.
While this is true, this is no different than any other change we'd make.  Yes, behavior would have to be changed slightly.

> So please add add a preference for configuring this and consider to make the
> download time the default setting because it's more understandable for the user
> - how much of the users are interested in the modification date on a server?
And how many of them are interested in the download time?  I'll also point out that the download time is stored in the download manager, so you can get that information there.

Per my initial decision in bug 178506, this is WONTFIX.  It shouldn't be too hard to make an add-on to revert the behavior FWIW.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
I agree, ADD it in te config file or something, as EVERY other browser puts the PC time into modified why not just add it as a switch.
Duplicate of this bug: 549255
Duplicate of this bug: 550283
ALL other browser are right and firefox is WRONG, and this is a BUG and it not really RESOLVED and I understand it WON'T get fixed, as this is how BROWSERS do things. I agree this is NOT how FTP programs download stuff but what FTP program has right click save image as ??????. This has been the case since at least the early 1990's WHY change things NOW?
I would have thought that there were more important things to fix with firefox (like why it doesn't render some pages correctly when other browsers DO) than to mess with a setting that been there since the VERY first release and is the SAME as every other browser.
(In reply to comment #8)
> WHY change things NOW?

Because the fix has been overdue for so long, and people are tired of fighting the difficulty of extracting the actual object URL from automatic download URLs to move to a real downloader, capable of fetching the file from the server without making _any_ changes to it. A changed timestamp constitutes a file modification, something some people have little or no no tolerance for. Now Firefox can be described as a real downloader instead of a downloader wannabe like all the broken browsers.

If you want the timestamp on a file downloaded by Firefox to be different from that on the server, you can change it yourself, which is much easier than discovering what it was on the server to change it back after a pseudo-downloader changed it to current.
It MUST have been important to fix as it took 16 years plus to do. But ALMOST everybody uses a dedicated downloader these days and they all have the option to change or keep the server date. Well at least the 3-4 I've tried have.
(In reply to comment #10)
> (In reply to comment #8)
> > WHY change things NOW?
> 
> Because the fix has been overdue for so long, and people are tired of fighting
> the difficulty of extracting the actual object URL from automatic download URLs
> to move to a real downloader, capable of fetching the file from the server
> without making _any_ changes to it. A changed timestamp constitutes a file
> modification, something some people have little or no no tolerance for. Now
> Firefox can be described as a real downloader instead of a downloader wannabe
> like all the broken browsers.
> 
> If you want the timestamp on a file downloaded by Firefox to be different from
> that on the server, you can change it yourself, which is much easier than
> discovering what it was on the server to change it back after a
> pseudo-downloader changed it to current.

You talk of the firefox download as if it's on par with getright or something. The firefox built in downloader is at best average. I thought the built in downloader in firefox was just to get you going as it's rather poor and lacking compared to all the real downloaders out there. So I look forward to this new and improved real downloader instead of a downloader wannabe you talk about.

I always thought that firefox was a browser with a built in downloader and not a downloader with built in browser.
This hoses your file order in the downloads widget in the Mac OS X dock.  Safari apparently used to do this and they changed it back to setting it to the download time.  Every other browser in existence sets it to the download time.

I think this is going to piss off a lot of users.  (myself included, this hoses my workflow trying to locate things I just downloaded).

For those who want the old behavior back, there is an extension for it now:
https://addons.mozilla.org/en-US/firefox/addon/93121/

I suspect those who want the server's timestamp are in the minority - the extension ought to be to set the server timestamp, and default behavior should be the current time.  Mainly because people expect things they just downloaded to sort to the top of their downloads folder.
Whiteboard: [use https://addons.mozilla.org/en-US/firefox/addon/93121 to get the old behavior]
(In reply to comment #13)
 
> I suspect those who want the server's timestamp are in the minority - the
> extension ought to be to set the server timestamp, and default behavior should
> be the current time.  Mainly because people expect things they just downloaded
> to sort to the top of their downloads folder.

I agree with Dave. These are the kind of things that put off people like my dad (who's not computer savvy) from using Firefox. You're used to something working fine and all of a sudden, you're thrown off by a seemingly random change.

Seriously, how many people in the real world care about what timestamp was set on the server?
(In reply to comment #13)
> I suspect those who want the server's timestamp are in the minority - the
> extension ought to be to set the server timestamp, and default behavior should
> be the current time.  Mainly because people expect things they just downloaded
> to sort to the top of their downloads folder.

ALL other downloading software I have ever used has ALWAYS applied the CURRENT date and time to ALL files.  I sort my file managers (yes, plural) by date with newest on top.  I never had to be concerned with what is a "Create" time or what is a "Modify" time.  

> For those who want the old behavior back, there is an extension for it now:
> https://addons.mozilla.org/en-US/firefox/addon/93121/

If the developers of FF believe that the familiar and universal behavior is somehow wrong, and they want to show the server's timestamp (which is utterly useless to the end user) by default, that's fine.  But then they should include a preference option to restore the familiar behavior, without requiring an add-on.
Bug 178506 was backed out and is not WONTFIX, so this is now INVALID.
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.