Last Comment Bug 545431 - Make xulrunner support MOZ_PKG_PRETTYNAMES
: Make xulrunner support MOZ_PKG_PRETTYNAMES
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: P3 normal (vote)
: ---
Assigned To: Rail Aliiev [:rail] ⌚️ET
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 497803
  Show dependency treegraph
 
Reported: 2010-02-10 09:52 PST by Rail Aliiev [:rail] ⌚️ET
Modified: 2010-04-12 22:50 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.4-fixed
.10-fixed


Attachments
Proposed fix (669 bytes, patch)
2010-02-10 09:52 PST, Rail Aliiev [:rail] ⌚️ET
ted: review+
Details | Diff | Splinter Review
Proposed patch v2 (2.06 KB, patch)
2010-02-12 03:01 PST, Rail Aliiev [:rail] ⌚️ET
ted: review+
dveditz: approval1.9.2.4-
dveditz: approval1.9.1.10-
Details | Diff | Splinter Review
fix-mac-sdk-name.diff (939 bytes, patch)
2010-03-04 21:27 PST, Rail Aliiev [:rail] ⌚️ET
ted: review+
dveditz: approval1.9.2.4-
dveditz: approval1.9.1.10-
Details | Diff | Splinter Review
combined patch for 1.9.1 (3.64 KB, patch)
2010-03-31 23:02 PDT, Rail Aliiev [:rail] ⌚️ET
mbeltzner: approval1.9.1.10+
Details | Diff | Splinter Review
combined patch for 1.9.2 (3.53 KB, patch)
2010-03-31 23:02 PDT, Rail Aliiev [:rail] ⌚️ET
mbeltzner: approval1.9.2.4+
Details | Diff | Splinter Review

Description Rail Aliiev [:rail] ⌚️ET 2010-02-10 09:52:16 PST
Created attachment 426268 [details] [diff] [review]
Proposed fix

Working on bug 497803 I get the following error:

make -f client.mk sdk
....
cd ../../dist && gtar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f - xulrunner-sdk | bzip2 -vf > linux-i686/en-US/xulrunner-3.6.sdk.tar.bz2
/bin/sh: linux-i686/en-US/xulrunner-3.6.sdk.tar.bz2: No such file or directory

Seems like make-sdk target requires additional step.

Please review the following patch and consider to land it to branches too.
Comment 1 Rail Aliiev [:rail] ⌚️ET 2010-02-12 03:00:36 PST
Ted,

thanks a lot for your review.

I would like to retitle this bug and obsolete the patch with another one.

Xulrunner uses its own directory layout and naming convention for releases (when MOZ_PKG_PRETTYNAMES is set). See the current directory layout:
http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.9.2rc1/

Please review the following patch and consider to land it to branches.
Comment 2 Rail Aliiev [:rail] ⌚️ET 2010-02-12 03:01:30 PST
Created attachment 426649 [details] [diff] [review]
Proposed patch v2
Comment 3 Ted Mielczarek [:ted.mielczarek] 2010-02-12 04:57:00 PST
You are of course free to do what you like with your own bugs.
Comment 4 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-02-19 14:44:13 PST
ted: ping on the r?
Comment 5 Ted Mielczarek [:ted.mielczarek] 2010-02-20 05:58:18 PST
Sorry, queue is backed up a bit again. Will tend to it monday or so.
Comment 6 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-02-24 07:51:52 PST
(In reply to comment #5)
> Sorry, queue is backed up a bit again. Will tend to it monday or so.
ping?
Comment 7 Ted Mielczarek [:ted.mielczarek] 2010-02-24 11:14:57 PST
Comment on attachment 426649 [details] [diff] [review]
Proposed patch v2

Ok, this looks fine, sorry for the delay.
Comment 8 Ted Mielczarek [:ted.mielczarek] 2010-02-24 11:15:44 PST
Rail pointed me at: https://wiki.mozilla.org/Releases/Firefox_3.5.7/BuildNotes#XULRunner_build

which is the notes on how the directory structure is currently generated by hand(!)
Comment 9 Ted Mielczarek [:ted.mielczarek] 2010-03-03 08:22:04 PST
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/cdd4b50a322f
Comment 10 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-03-03 08:27:41 PST
1) Ted: thanks for landing this on mozilla-central.

2) We need this landed on each branch where we are providing xulrunner releases, hence the requests for 191, 192.
Comment 11 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-03-03 08:30:46 PST
this time with the flags, lost during mid-air-collision.
Comment 12 Daniel Veditz [:dveditz] 2010-03-03 12:45:59 PST
Not blocking, ask for approval on the patch if you want to get it in.
Comment 13 Nick Thomas [:nthomas] 2010-03-04 18:03:41 PST
I think this bug regressed the naming of the SDKs. Previously we had 
  xulrunner-1.9.3a3pre.en-US.mac-i386.sdk.tar.bz2
and now its
  xulrunner.en-US.mac-i386.sdk.tar.bz2

Looks like 
  http://hg.mozilla.org/mozilla-central/rev/cdd4b50a322f#l2.22
left out a -$(MOZ_PKG_VERSION).
Comment 14 Rail Aliiev [:rail] ⌚️ET 2010-03-04 21:27:18 PST
Created attachment 430520 [details] [diff] [review]
fix-mac-sdk-name.diff
Comment 15 Nick Thomas [:nthomas] 2010-03-17 20:04:06 PDT
Comment on attachment 430520 [details] [diff] [review]
fix-mac-sdk-name.diff

http://hg.mozilla.org/mozilla-central/rev/e93efbc87c88

Verifying this fix relies on bug 552339 giving us back XULRunner nightlies.
Comment 16 Rail Aliiev [:rail] ⌚️ET 2010-03-24 08:30:03 PDT
(In reply to comment #15)
> (From update of attachment 430520 [details] [diff] [review])
> http://hg.mozilla.org/mozilla-central/rev/e93efbc87c88
> 
> Verifying this fix relies on bug 552339 giving us back XULRunner nightlies.

In other words, everything is OK after applying both patches.
Comment 17 Daniel Veditz [:dveditz] 2010-03-29 10:55:32 PDT
Comment on attachment 430520 [details] [diff] [review]
fix-mac-sdk-name.diff

Please get us a combined branch-merged patch of what you want us to approve for branches.
Comment 18 Rail Aliiev [:rail] ⌚️ET 2010-03-31 23:02:11 PDT
Created attachment 436427 [details] [diff] [review]
combined patch for 1.9.1
Comment 19 Rail Aliiev [:rail] ⌚️ET 2010-03-31 23:02:51 PDT
Created attachment 436428 [details] [diff] [review]
combined patch for 1.9.2
Comment 20 Ted Mielczarek [:ted.mielczarek] 2010-04-07 12:33:09 PDT
You don't need re-review unless you've made significant changes. Just merging two patches into one is fine. If that's all you had to do, then feel free to simply request approval on these pathes.
Comment 21 Mike Beltzner [:beltzner, not reading bugmail] 2010-04-07 13:08:11 PDT
Comment on attachment 436428 [details] [diff] [review]
combined patch for 1.9.2

a=beltzner for 1.9.2.4 and 1.9.1.10
Comment 22 Reed Loden [:reed] (use needinfo?) 2010-04-12 21:22:17 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/45ee15e1d407
Comment 23 Reed Loden [:reed] (use needinfo?) 2010-04-12 22:50:31 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a2f5c0776892

Note You need to log in before you can comment on or make changes to this bug.