Last Comment Bug 545488 - Using astral plane code points in a bug report fails
: Using astral plane code points in a bug report fails
Status: RESOLVED DUPLICATE of bug 405011
:
Product: Bugzilla
Classification: Server Software
Component: Creating/Changing Bugs (show other bugs)
: 3.4.5
: All All
-- minor with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: default-qa
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-10 12:34 PST by David Given
Modified: 2012-11-02 17:47 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image David Given 2010-02-10 12:34:43 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.1 (KHTML, like Gecko) Chrome/5.0.323.0 Safari/533.1
Build Identifier: version 3.4.5

I have just tried to file a bug on Thunderbird concerning a problem with its Unicode support. I included an example of the text in question; Bugzilla failed spectacularly, truncating my bug report at the first astral plane code point.

The bug report in question is https://bugzilla.mozilla.org/show_bug.cgi?id=545478.

Reproducible: Always

Steps to Reproduce:
1. Attempt to file a bug report using some text containing characters in the Unicode astral plane range --- there's an example at http://twitter.com/hjalfi/statuses/8690602802.
Actual Results:  
The bug report is truncated at the first astral plane code point.

Expected Results:  
I see the text in the bug report.

This *may* have security implications --- I don't know why it's truncating the bug report, but it smells like it's misparsing the text, and that sort of thing needs looking at closely in case it's doing something unexpected.
Comment 1 User image David Given 2010-02-10 12:35:11 PST
I shall now attempt to add the text sample in question to this bug report to see whether 'Additional Comments' fails too.
Comment 2 User image David Given 2010-02-10 12:35:40 PST
Dodgy text start: [
Comment 3 User image David Given 2010-02-10 12:36:14 PST
Yes, that truncated it as well.
Comment 4 User image Max Kanat-Alexander 2010-02-10 13:39:21 PST
My guess would be that MySQL is doing it, actually, not Bugzilla. Where in the Unicode space do these characters start?
Comment 5 User image David Given 2010-02-10 13:55:22 PST
I've heard rumours MySQL doesn't support astral plane properly. These specific characters are MATHEMATICAL BOLD FRAKTUR from U+1D56C to U+1D59F, but I suspect it would work with anything above U+FFFF.
Comment 6 User image Max Kanat-Alexander 2010-02-10 13:59:58 PST
Ahh, do you know what version of Unicode those were added in? It may be that either Perl or MySQL aren't using that version of Unicode.
Comment 7 User image David Given 2010-02-10 14:04:08 PST
3.1.0, apparently:

http://www.fileformat.info/info/unicode/char/1d56c/index.htm

(Which came out in 2001...)
Comment 8 User image Frédéric Buclin 2012-11-02 17:47:33 PDT

*** This bug has been marked as a duplicate of bug 405011 ***

Note You need to log in before you can comment on or make changes to this bug.