[OOPP] After telling plugin crashed UI to reload page, a browser restart is required for video to play

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [bugday0601], URL)

(Reporter)

Description

8 years ago
Restarting browser required for video to play after telling plugin crashed UI to reload page

STR:
1) http://www.youtube.com/watch?v=d1X4r2nHSb0&feature=rec-rn-2r-3-HM
2) Kill the mozilla-runtime process
3) Telling the plugin crashed UI to reload the page
4) Video doesn't start to play, plugin loading spinner just spins.

Ctrl+F5 has same effect. Closing the tab, restarting the browser, and loading the page is required in for the video to play again.

Does not happen with http://www.youtube.com/watch?v=2X4j_2Kgi9o&feature=related
(Reporter)

Updated

8 years ago
Summary: Restarting browser required for video to play after telling plugin crashed UI to reload page → [OOPP] Restarting browser required for video to play after telling plugin crashed UI to reload page
(Reporter)

Updated

8 years ago
Summary: [OOPP] Restarting browser required for video to play after telling plugin crashed UI to reload page → [OOPP] After telling plugin crashed UI to reload page, a browser restart is required for video to play
(Reporter)

Comment 1

8 years ago
This should be a blocker since this bug defeats the purpose of OOPP since a browser restart is required after a plugin crashes.
Severity: normal → major
blocking2.0: --- → ?

Comment 2

8 years ago
WFM, Windows 7. I suspect that the cache may end up in a less-than-perfect state here, but I haven't seen that cause problems of this sort.
Blocks: 478976
I didn't realize this bug was filed, but I did see it too after using yesterday's hourly, and opened bug 545976.  But now I cannot reproduce, I am running 32-bit windows 7, flash 10.0.42.34

Comment 4

8 years ago
Dale, do you also have adblock plus installed?

Updated

8 years ago
Duplicate of this bug: 545976
No, I just have these extensions though:

Microsoft .NET Framework Assistant 1.1
Nightly Tester Tools 2.0.3
ProCon Latte 1.7.9.8x
Test Pilot 0.4
(Reporter)

Comment 7

8 years ago
Same extensions for me except I don't have the ProCon latte extension.  My flash version is 10.1.51.45
Also WFM, win7 x64 latest flash plugin: 10.0.45.2

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100212 Minefield/3.7a2pre Firefox/3.6 ID:20100212145610
Sounds bad, we should figure out what's up with this before we release anything...
Blocks: 539055
blocking2.0: ? → beta1

Comment 10

8 years ago
WFM in today's nightly, I really don't think this is a blocker.
No longer blocks: 539055
blocking2.0: beta1 → -

Comment 11

8 years ago
WFM on Linux-x86 with Flash 10.0r42, to be precise.
(Reporter)

Comment 12

8 years ago
I can't reproduce this either using my STR because I forgot to include that I'm visting that URL from the awesomebar results.  This is the only way I can reproduce this.
I just reproduced it on the URL from comment 0 with a current hourly
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100219 Minefield/3.7a2pre (.NET CLR 3.5.30729) ID:20100219175448

Its similiar to my experience testing Hulu with Fullscreen crashing the browser and dropping video after a pause; as here, "pause" the video before killing the plugin, might just be the key STR after step 1.

It must be dropping the video feed or URL, which cannot be picked up on the webpage when the plugin restarts.  Fwiw, I also seen a similar comment in another OOPP bug 542263 comment 6 mentioning the feed is gone.

The only other thing I had running was another flash video in another tab; testing last.fm/radio bug 547247.

I just played the video for a few seconds or so.  Hit pause.  Killed Mozilla-Runtime, reloaded the page from the plugin-ui and the video doesn't play, I have to restart the browser.
BUILD:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100601 BRI/1 Minefield/3.7a5pre

PLUGIN:
Flash 10.0.45.2

Works for me using the latest trunk nightly.  I'm resolving this WORKSFORME.  Reporter, please reopen if you can reproduce this behaviour on the latest Minefield and Flash versions.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [bugday0601]
WFM, too (on trunk).
Sorry, I forgot:
OS: Ubuntu 10.04
PLUGIN: 10.0.45.2
BUILD: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5pre) Gecko/20100601 Minefield/3.7a5pre
You need to log in before you can comment on or make changes to this bug.