Closed Bug 545703 Opened 11 years ago Closed 10 years ago

Support changing zooming via text zoom

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mfinkle, Assigned: madhava)

References

(Depends on 1 open bug)

Details

Fennec currently scales the viewport when zooming in or oout. There have been requests to support zooming via text zoom (changing the text size) and also by doing a reflow zoom, like desktop firefox.
In microb browser we have very special shortcut for that SHIFT+CTRL+R+I - will enable zoom with reflow...
Component: General → Panning/Zooming
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 599624
tracking-fennec: --- → ?
Depends on: 578179
Duplicate of this bug: 603006
Lets make a decision for final
Assignee: nobody → madhava
tracking-fennec: ? → 2.0+
Summary: Support changing zooming via text zoom and/or zooming via reflow → Support changing zooming via text zoom
I tried to test the bigger text add-on but I can't seem to get it to do anything. It froze up fennec when I first loaded a page with it. I eventually got to click update on the plugin page and it says a compatibility update was applied but the page I'm trying to look at hasn't changed.
What about relow on zoom? If it's controversial, I could see this being a user-visible pref (and I'm usually dead-set against them).
(In reply to comment #6)
> I tried to test the bigger text add-on but I can't seem to get it to do
> anything.

After installing the add-on, open the site menu and choose "Bigger Text" to toggle text zoom for the current tab.  There's also a new version 1.0 uploaded to AMO but not yet reviewed, which adds several options including an option to enable zoom in new tabs by default:

https://addons.mozilla.org/en-US/mobile/addon/235278/versions/

(In reply to comment #7)
> What about relow on zoom? If it's controversial, I could see this being a
> user-visible pref (and I'm usually dead-set against them).

Reflow on zoom is bug 578179, which is currently blocking-fennec:2.0-.
What about Maemo devices? The current behavior makes it nearly impossible for me to use Fennec for reading feeds with Google Reader. You have to zoom in to be able to read the content because its too small, but at the same time you will have to pan all the time. :/
(In reply to comment #9)
> What about Maemo devices?

I'm not sure what you mean - we know this is a problem on both Maemo and Android, and whatever we do to fix it, we will do it on all platforms.

> The current behavior makes it nearly impossible for
> me to use Fennec for reading feeds with Google Reader.

As a workaround for Google Reader specifically, the mobile version at http://www.google.com/reader/i/ works great in Fennec.  (But of course the same problem exists on many other sites, which is why this bug is open.)
(In reply to comment #10)
> I'm not sure what you mean - we know this is a problem on both Maemo and
> Android, and whatever we do to fix it, we will do it on all platforms.

Well on bug 578179 only Android is the topic. I just wanted to get feedback about Maemo. Thanks!

> As a workaround for Google Reader specifically, the mobile version at
> http://www.google.com/reader/i/ works great in Fennec.  (But of course the same
> problem exists on many other sites, which is why this bug is open.)

Haven't known about this page. Works for now until the zoom issue is fixed. Thanks again.
Duplicate of this bug: 611555
There is an add-on, Bigger Text, that serves this purpose.
Status: NEW → RESOLVED
tracking-fennec: 2.0+ → ---
Closed: 10 years ago
Resolution: --- → WONTFIX
Blocks: 538117
You need to log in before you can comment on or make changes to this bug.