Last Comment Bug 545972 - TM: gcc warnings in jstracer.cpp
: TM: gcc warnings in jstracer.cpp
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2010-02-12 17:38 PST by Andreas Gal :gal
Modified: 2011-07-09 21:23 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andreas Gal :gal 2010-02-12 17:38:03 PST
../jstracer.cpp: In member function ‘nanojit::LIns* js::TraceRecorder::scopeChain()’:
../jstracer.cpp:7726: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In member function ‘void js::TraceRecorder::putActivationObjects()’:
../jstracer.cpp:9738: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In member function ‘js::AbortableRecordingStatus js::TraceRecorder::record_EnterFrame(uintN&)’:
../jstracer.cpp:9809: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp:9820: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp:9822: warning: dereferencing type-punned pointer will break strict-aliasing rules
In file included from ../jstracer.cpp:15404:
../jsrecursion.cpp: In member function ‘js::AbortableRecordingStatus js::TraceRecorder::slurpDownFrames(jsbytecode*)’:
../jsrecursion.cpp:529: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::CountSlotsVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::CountSlotsVisitor]’
../jstracer.cpp:2558:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::FlushNativeStackFrameVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::FlushNativeStackFrameVisitor]’
../jstracer.cpp:3303:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::ImportBoxedStackSlotVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::ImportBoxedStackSlotVisitor]’
../jstracer.cpp:3524:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::AdjustCallerStackTypesVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::AdjustCallerStackTypesVisitor]’
../jstracer.cpp:3870:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::DetermineTypesVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::DetermineTypesVisitor]’
../jstracer.cpp:5983:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::CaptureTypesVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::CaptureTypesVisitor]’
../jstracer.cpp:15394:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::ImportFrameSlotsVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::ImportFrameSlotsVisitor]’
../jsrecursion.cpp:624:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::BuildNativeFrameVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::BuildNativeFrameVisitor]’
../jstracer.cpp:1886:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, JSObject*, unsigned int, unsigned int, uint16*) [with Visitor = js::BuildNativeFrameVisitor]’
../jstracer.cpp:2896:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::DefaultSlotMap]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::DefaultSlotMap]’
../jstracer.cpp:1886:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, JSObject*, unsigned int, unsigned int, uint16*) [with Visitor = js::DefaultSlotMap]’
../jstracer.cpp:1913:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, unsigned int, const js::SlotList&) [with Visitor = js::DefaultSlotMap]’
../jstracer.cpp:4575:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::TypeCompatibilityVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::TypeCompatibilityVisitor]’
../jstracer.cpp:1886:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, JSObject*, unsigned int, unsigned int, uint16*) [with Visitor = js::TypeCompatibilityVisitor]’
../jstracer.cpp:1913:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, unsigned int, const js::SlotList&) [with Visitor = js::TypeCompatibilityVisitor]’
../jstracer.cpp:6187:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
../jstracer.cpp: In function ‘bool js::VisitFrameSlots(Visitor&, unsigned int, JSStackFrame*, JSStackFrame*) [with Visitor = js::CheckEntryTypeVisitor]’:
../jstracer.cpp:1847:   instantiated from ‘bool js::VisitStackSlots(Visitor&, JSContext*, unsigned int) [with Visitor = js::CheckEntryTypeVisitor]’
../jstracer.cpp:1886:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, JSObject*, unsigned int, unsigned int, uint16*) [with Visitor = js::CheckEntryTypeVisitor]’
../jstracer.cpp:1913:   instantiated from ‘void js::VisitSlots(Visitor&, JSContext*, unsigned int, const js::SlotList&) [with Visitor = js::CheckEntryTypeVisitor]’
../jstracer.cpp:6256:   instantiated from here
../jstracer.cpp:1815: warning: dereferencing type-punned pointer will break strict-aliasing rules
Assembler.cpp
Comment 1 Andreas Gal :gal 2010-02-12 17:38:20 PST
../jsarray.cpp: In function ‘JSBool ResizeSlots(JSContext*, JSObject*, uint32, uint32, bool)’:
../jsarray.cpp:327: warning: comparison is always false due to limited range of data type
jsatom.cpp
Comment 2 Nicholas Nethercote [:njn] 2011-07-09 21:23:08 PDT
These are long gone, AFAIK.

Note You need to log in before you can comment on or make changes to this bug.