Closed Bug 545982 Opened 10 years ago Closed 10 years ago

Firefox doesn't preserve file timestamps when downloading files

Categories

(Toolkit :: Downloads API, defect)

1.9.2 Branch
x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 178506

People

(Reporter: andris, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2) Gecko/20100115 MRA 5.6 (build 3278) Firefox/3.6 sputnik unknown
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2) Gecko/20100115 MRA 5.6 (build 3278) Firefox/3.6 sputnik unknown

Firefox doesn't preserve file timestamps when downloading files upon the user request. The downloaded files get the current timestamp instead of the original  which is available at the time of download.

Reproducible: Always

Steps to Reproduce:
1. Try to download any file from any source.
2. Wait for the download completion.
3. Check file timestamp.
Actual Results:  
The file would have the local timestamp instead of the original.

Expected Results:  
The file must have the original timestamp which is available at the time of download via the Last-Modified HTTP header or by inspecting the FTP listing. The famous wget utility as well as many other download managers preserve timestamps.
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
Version: unspecified → 1.9.2 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 178506
v
damn, i didn't found it because it's marked fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.