Closed Bug 546072 Opened 12 years ago Closed 12 years ago

[OOPP] List plugin crashes in about:crashes

Categories

(Core :: Plug-ins, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: matt, Unassigned)

References

Details

As far as I can tell, the crash reports submitted for plugin crashes don't get listed under about:crashes.  Being listed under about:crashes would be useful for filing bug reports.
Why do you say that ? I can see mine, for instance crash ID 6ca3a075-9d43-40da-8737-67c862100211 I do agree that you can't see if a crash is a mozilla-related one, or one in a plugin.

Maybe you're not sending any crash-reports to Mozilla - the reporter respects that. But since you're not seeing the dialog box when a plugin has crashed, you can't toggle it on for this message only.
Blocks: OOPP
Summary: [OOPP] List plugin crashes in about:crash → [OOPP] List plugin crashes in about:crashes
Matthew: What OS are you seeing this on?
Oops, they *ARE* showing up in about:crashes.  I don't know why I thought they weren't.

Sorry about that.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
They actually don't show up for me. To reproduce:

* Go to http://www.tagesanzeiger.ch/panorama/vermischtes/Retter-in-der-Not-wird-zum-Helden/story/30144468
* Play video
* Right click on video during playback
* Hang
* Kill mozilla-runtime process
* See Firefox tell you "The Shockwave Flash plugin has crashed. Reload the page to try again. A crash report was submitted."
* Go to about:crashes -> no new crash shown

Gecko/20100214 Minefield/3.7a2pre on Linux.
Status: RESOLVED → REOPENED
OS: All → Linux
Hardware: All → x86
Resolution: WORKSFORME → ---
Comment #4 is a different bug. We obviously don't have crash reports when you kill mozilla-runtime, because it didn't crash. It's a bug that we say we submitted a report when we obviously couldn't have. I think that is a duplicate of bug 545712.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.