Last Comment Bug 546093 - Print dialog should not display the SVG output option when printing to a file
: Print dialog should not display the SVG output option when printing to a file
Status: VERIFIED FIXED
: verified1.9.2
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla1.9.3a2
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-14 05:55 PST by Mike Hommey [:glandium]
Modified: 2010-03-22 13:34 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.2-fixed
.9-fixed


Attachments
Patch (1.32 KB, patch)
2010-02-14 05:55 PST, Mike Hommey [:glandium]
no flags Details | Diff | Review
Patch (630 bytes, patch)
2010-02-14 05:59 PST, Mike Hommey [:glandium]
karlt: review+
dveditz: approval1.9.2.2+
dveditz: approval1.9.1.9+
Details | Diff | Review

Description Mike Hommey [:glandium] 2010-02-14 05:55:33 PST
Created attachment 426894 [details] [diff] [review]
Patch

Until bug 525998 is actually addressed, all currently released branches should force disabling the svg output option.
Comment 1 Mike Hommey [:glandium] 2010-02-14 05:59:22 PST
Created attachment 426895 [details] [diff] [review]
Patch

Hum... without unrelated changes this time
Comment 2 Reed Loden [:reed] (use needinfo?) 2010-02-14 09:51:35 PST
Comment on attachment 426895 [details] [diff] [review]
Patch

Please wait for review(s) to be completed before requesting branch approval.
Comment 3 Karl Tomlinson (ni?:karlt) 2010-02-14 12:34:56 PST
Comment on attachment 426895 [details] [diff] [review]
Patch

Looks good, thanks.
Comment 4 Karl Tomlinson (ni?:karlt) 2010-02-14 12:36:41 PST
Let's get this in on mozilla-central.
Comment 5 Karl Tomlinson (ni?:karlt) 2010-02-17 17:42:19 PST
http://hg.mozilla.org/mozilla-central/rev/b40f96c3d2ec
Comment 6 Mike Hommey [:glandium] 2010-02-17 23:15:15 PST
Flags have completely changed, what is the one for approval on branches, now ?
Comment 7 Steffen Wilberg 2010-02-18 01:48:07 PST
"approval1.9.2.2" for Firefox 3.6.2 and "approval1.9.1.9" for Firefox 3.5.9 on https://bugzilla.mozilla.org/attachment.cgi?id=426895&action=edit, I guess.

See https://wiki.mozilla.org/Releases/Flags on the various multi-state flags.
Comment 8 Mike Hommey [:glandium] 2010-02-18 02:24:14 PST
Comment on attachment 426895 [details] [diff] [review]
Patch

D'oh, I was looking for these flags at the wrong place...
Comment 9 Daniel Veditz [:dveditz] 2010-02-22 10:44:53 PST
Looks safe enough to approve, but how does adding postscript flags turn off SVG output?
Comment 10 Mike Hommey [:glandium] 2010-02-22 11:30:23 PST
Because it's unfortunately how this thing works. There is not even a flag for SVG, so you can't support, e.g. ps and svg but not pdf...

See http://git.gnome.org/browse/gtk+/tree/modules/printbackends/file/gtkprintbackendfile.c#n594
Comment 11 Karl Tomlinson (ni?:karlt) 2010-02-22 12:24:39 PST
That's even how the flags are documented:
"If neither GTK_PRINT_CAPABILITY_GENERATE_PDF  nor GTK_PRINT_CAPABILITY_GENERATE_PS  is specified, GTK+ assumes that all formats are supported."

Currently Mozilla only supports PDF and PS so it makes sense to explicitly specify these.
http://hg.mozilla.org/mozilla-central/annotate/ab74c935e321/widget/src/gtk2/nsDeviceContextSpecG.cpp#l478
Comment 12 Daniel Veditz [:dveditz] 2010-02-26 13:25:23 PST
Comment on attachment 426895 [details] [diff] [review]
Patch

Approved for 1.9.1.9 and 1.9.2.2, a=dveditz for release-drivers
Comment 14 Henrik Skupin (:whimboo) 2010-03-22 13:34:23 PDT
As given by Karl on IRC the problem here were the missing flags. If no flags are set, the dialog simply offers all possible output formats.

Verified fixed on 1.9.2 with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Also works on trunk with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100322 Minefield/3.7a4pre

Note You need to log in before you can comment on or make changes to this bug.