Closed Bug 546367 Opened 12 years ago Closed 12 years ago

CSS generated content doesn't work on form elements

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 241985

People

(Reporter: seddon.ryan, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Applying CSS generated content to a form element like a checkbox or radio input doesn't work. 

Reproducible: Always

Steps to Reproduce:
1. Go here http://www.thecssninja.com/demo/form_generated-content/
Actual Results:  
Page loads and doesn't display CSS generated content

Expected Results:  
CSS generated content should appear after form elements (a small image)

Safari, Chrome add generated content after checkboxes, radios and file inputs but not text inputs or textareas. Opera applies generated content to all form elements. IE8 behaves the same as Firefox.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 241985
You need to log in before you can comment on or make changes to this bug.