Wrong handling of -- in HTML Comments

VERIFIED DUPLICATE of bug 214476

Status

()

Core
HTML: Parser
--
minor
VERIFIED DUPLICATE of bug 214476
8 years ago
8 years ago

People

(Reporter: realname, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9.1.8pre) Gecko/20100111 SeaMonkey
Build Identifier: 

If you put -- between <!-- and -->, the parsing isn't predictable.

Reproducible: Always

Steps to Reproduce:
a -- b -- <!-- c -- d --> -- e -- f<br/>
<b>a</b> -- <b>b</b> -- <!-- <b>c</b> -- <b>d</b> --> e -- f
Actual Results:  
Displayed:
a -- b -- b -- d --> e -- f

Copy to Clipboard:
a -- b --  -- e -- f
a -->b -- d --> e -- f

Expected Results:  
a b e f
a b e f
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
Verified.  Note that the parsing is in fact quite predictable if you actually read the HTML and SGML specs...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

8 years ago
Oh, sorry :)

Other question: Why is copy to clipboard different?
If you have set html5.enable to true, loading documents into a browsing context and parsing a clipboard paste go through different parsers (as an interim measure).
You need to log in before you can comment on or make changes to this bug.