Last Comment Bug 54644 - -moz-float-edge sucks, should be taken out and shot
: -moz-float-edge sucks, should be taken out and shot
Status: RESOLVED INVALID
(py8ieh: file new bugs -- 1. marker o...
: css-moz
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: Future
Assigned To: buster
: Chris Petersen
Mentors:
Depends on:
Blocks: 54979
  Show dependency treegraph
 
Reported: 2000-09-28 23:44 PDT by Hixie (not reading bugmail)
Modified: 2001-06-22 06:19 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case showing one reason why -moz-float-edge sucks (530 bytes, text/html)
2000-09-28 23:54 PDT, Hixie (not reading bugmail)
no flags Details

Description Hixie (not reading bugmail) 2000-09-28 23:44:24 PDT
The CSS extension -moz-float-edge cannot be said to be buggy, since there is no
documentation (that I can find) telling us what it is supposed to do.

However, it is not a good solution to the problem it was trying to solve.

THE ORIGINAL PROBLEM:

The markup:

   <float> float </float>
   <block>
    <item> list item </item>
    <item> list item </item>
    <item> a much longer list item that must wrap </item>
    <item> final list item </item>  
   </block>


The wanted result:

   +-----------+ - - - - - - - - +
   | float     | 1. list item   
   |           | 2. list item    |
   +-----------+ 3. a much longer    
   |    list item that must wrap |
     4. final list item
   + - - - - - - - - - - - - - - +


The per-spec result:

   +-----------+ - - - - - - - - +
   | 1loat     | list item   
   | 2.        | list item       |
   +-3.--------+ a much longer    
   |    list item that must wrap |
     4. final list item
   + - - - - - - - - - - - - - - +


Our current result:

   +-----------+ - - - - - - - - +
   | float     | 1. list item   
   |           | 2. list item    |
   +-----------+ 3. a much longer    
                    list item that 
   |                must wrap    |
     4. final list item
   + - - - - - - - - - - - - - - +

Analagous situations exist for the right hand side.


AN ADDITIONAL PROBLEM THAT THIS PROPERTY INTRODUCES 

Markup:

   <float>
      <float> a float that overflows the parent </float>
      <item> an item with -moz-float-edge set </item>
   </float>

Rendering:

   +------------+
   |+-----------+-----------------------+ +-----------------+
   || a float that overflows the parent | | an item with    |
   |+-----------+-----------------------+ | -moz-float-edge |
   |            |                         | set             |
   +------------+                         +-----------------+

That is SO wrong!!! (see test case)


THE SOLUTION

My proposed solution involves changing the spec to say that the marker box, in
the presence of floats, should be placed relative to the first line box. I have
already sent this proposal to www-style (from way back in 1998!):

   http://lists.w3.org/Archives/Public/www-style/1998Dec/0066.html

I will send this to the WG again at some point.

I propose that we get rid of -moz-float-edge and use this solution instead.
Comment 1 Hixie (not reading bugmail) 2000-09-28 23:54:12 PDT
Created attachment 15808 [details]
Test case showing one reason why -moz-float-edge sucks
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2000-09-29 10:54:43 PDT
I don't see how this is a CSS1 bug (in a strict sense, anyway, although it is
related to the CSS1 float property...).  Removing CSS1 keyword.  However, I
filed bug 54696 and added the CSS1 keyword to that bug.
Comment 3 Hixie (not reading bugmail) 2000-09-29 18:43:06 PDT
It's a CSS1 bug because the test case renders incorrectly per CSS1.
Comment 4 Hixie (not reading bugmail) 2000-10-01 16:50:37 PDT
Taking QA per managerial policy.
Comment 5 Hixie (not reading bugmail) 2000-10-01 16:58:17 PDT
Taking QA per managerial policy.
Comment 6 Hixie (not reading bugmail) 2000-11-09 17:52:54 PST
We discused this at the W3C CSS Face to Face this week. The tentative 
conclusion was that -moz-float-edge in fact did not suck, but was merely a part
of a bigger solution, that includes the marker thing.

The additional problem listed above is a separate bug that we should fix.
Marking this bug INVALID for now. I will open the other bugs.
Comment 7 Hixie (not reading bugmail) 2001-06-22 06:19:55 PDT
reassigning qa since i resolved the bug

Note You need to log in before you can comment on or make changes to this bug.