upgrading to camino 2.0.1 trackpad and mouse don't work

RESOLVED WORKSFORME

Status

Camino Graveyard
OS Integration
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: ivangfour, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9.0.19pre) Gecko/2010021600 Camino/2.1a1pre (like Firefox/3.0.19pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9.0.19pre) Gecko/2010021600 Camino/2.1a1pre (like Firefox/3.0.19pre)

in the camino 1.6.9 both trackpad and mouse work well. 
In the camino 2.0.1 i can't scroll web pages vertically or horizzontally using mouse wheel or two finger scroll on trackpad.

I have a ibook 12" PPC G4 1.33 GHz , Tiger 10.4.11

I tried to reinstall camino but nothing appened.

Thanks.


Reproducible: Always
Since iBooks don't have native support for scrolling or multi-touch on their trackpads, it sounds like you've been using some sort of third party mouse/trackpad driver or hack, and that piece of software doesn't work with Camino 2.
(Reporter)

Comment 2

8 years ago
Thank you for answer Smokey Ardisson!

The latest ibook models have native support for scrolling or multi-touch

http://support.apple.com/kb/SP43

furthermore two-fingers/mousewheel scrolling works well with firefox, safari, and Camino 1.6.9. 

oh! i note that it works in the "additional comment" window but not in the main window...that's funny!


Thanks,
bye!
(Reporter)

Comment 3

8 years ago
Sorry for my pressing...
i would say that the vertical arrows in the scroll bar don't work too. If i click on them the page doesn't scroll. 

 I Hope to be helpful.
(In reply to comment #2)
> The latest ibook models have native support for scrolling or multi-touch
> 
> http://support.apple.com/kb/SP43

Huh, OK.
 
> furthermore two-fingers/mousewheel scrolling works well with firefox, safari,
> and Camino 1.6.9. 

What version of Firefox?  Does it work in Firefox 3.0.18?
(Reporter)

Comment 5

8 years ago
Smokey, you are great!

In Firefox 3.6 two-fingers/mousewheel scrolling and vertical arrows all are ok!

but in Firefox 3.0.18 (http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0.18/mac/it/)none of these works. Just like in Camino (now 2.0.2)

What should i do?

Thank you very much!

Comment 6

8 years ago
Works for me on 10.4-Intel, so it might be a PPC-only issue. Unfortunately, my only PPC machine has 10.3, so I can't test Camino 2. 

Smokey, could trying the experimental 2.1 build turn out useful to find out where the problem is?
(In reply to comment #6)
> Smokey, could trying the experimental 2.1 build turn out useful to find out
> where the problem is?

Only if it doesn't work :P

I'm still completely puzzled how scrolling might be broken in Gecko 1.9.0.

ivangfour, can you try 2.0.2 with a temporary fresh profile, just to rule out any profile weirdness?  http://pimpmycamino.com/parts/troubleshoot-camino can automate this for you.
(Reporter)

Comment 8

8 years ago
ok, i tried with a temporary fresh profile using troubleshoot-camino but nothing happened. It non depends on the profile. There is something in Camino 1.6.9 that has been forgotten for Camino 2.0.x
(Reporter)

Comment 9

8 years ago
Nothing change with the last version of Camino 2.0.3.
Trackpad and mousewheel don't scroll web pages.
It doesn't seem likely that we'll be able to figure out what's wrong with Gecko 1.9.0 such that it doesn't like the trackpad and mousewheel on your iBook.

Based on what you said in comment 5, though, trackpad/mousewheel scrolling should work for you in a nightly build, though: http://caminobrowser.org/contribute/#nightly
(Reporter)

Comment 11

8 years ago
Thank you,
the last nightly works well. Both mouse and trackpad scroll vertically and horizontally.

Arrow also work.
Given that scrolling works with Gecko 1.9.2 based Camino nightlies, resolving as WorksForMe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.