Closed Bug 546666 Opened 12 years ago Closed 11 years ago

[OOPP] switching tab when pdf is loading causes issues

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: maini10, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre (.NET CLR 3.5.30729)

Trying to switch tabs when a pdf files is loading, the user can't show again the tab with pdf.

Reproducible: Always

Steps to Reproduce:
1. Open one or more tab
2. Click on pdf link and wait for the file loading
3. While pdf plugin load the file, click to another tab
Actual Results:  
When you click again on the title of tab with pdf plugin, the page is not shown but Firefox still display the content of the last tab used before.

Expected Results:  
Firefox should show the page with pdf (eventually blank if loading is not complete).
It doesn't happen when pdf is immediately loaded, this need that pdf file is quite large and slow to load.
Blocks: OOPP
I think it is caused by a long wait before plugin loading. Mozilla-runtime process seems to wait something without ends. I hope that attachment could be useful.
No longer reproducible with latest version
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.