Closed Bug 546702 Opened 10 years ago Closed 10 years ago

Maemo Image SD-v6

Categories

(Release Engineering :: General, defect, P3, minor)

ARM
Maemo

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 551315

People

(Reporter: jhford, Unassigned)

References

Details

Attachments

(2 files)

Its that time again.  We need a new N810 rootfs.  We are going to add:
-dropbear and remove OpenSSH to save memory
-screen diming using gconftool-2:
<code>gconftool-2 --set /system/osso/dsm/display/enable_power_saving --type bool false
gconftool-2 --set /system/osso/dsm/display/display_dim_timeout --type int 99999999
gconftool-2 --set /system/osso/dsm/display/display_blank_timeout --type int 99999999
gconftool-2 --set /system/osso/dsm/display/display_brightness --type int 1</code>
There is a python-gconf package, but i don't think we should install it for something this simple.  If there isn't gconftool-2, lets re-investigate using python-conf.  This needs to be run at least once, and better if it is on each boot in case this configuration gets overwritten.  The above code is what works for the N900 but might require modifications to work on n810
-disable power saving
-Add RF Room wifi and remove Mozilla-Build
also, we should do self.addStep(ShellCommand,
            command='echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor',
            description=['disable', 'scaling', 'governor'],
            haltOnFailure=True,
        )
in the startup script instead of the factory
Getting this out of triage; this will be jhford or me.
Assignee: nobody → jhford
Hm, we may want to update twisted/buildbot too -- didn't you say that the lingering non-connected connectedness issues went away?
Depends on: 538523
yes, they seem to both be better.  We don't need *any* mozilla specific patches for this, which is nice.  I can cross compile the new twisted the same way we do on the n900 so that it is installed to the system python.
maemo-n810-03:

- uninstalled home tutorial applet, moredimmingoptions, openssh*, map.
- removed mozilla-build ssid; added rf room ssid.
- tried the gconftool-2 stuff, which seems to work so far (didn't try long idle times); didn't put in a script yet.
- kept the hostname as ref to avoid connecting to buildbot
- installed dropbear ssh server/client and successfully ssh'ed in as root

I'm going to leave this up in the rf room and temporarily remove it from the ssh monitoring... we can do the rest of the above to it and then take an image.
One thing that'd be nice for the N810 would be to start a fresh refimage.  This would also allow us to put a bunch of the tools that we are using for the N900 on the N810.  Creating a fresh n810 refimage isn't be too long of a process and will get us a few important wins including the above changes as well as cvs, hg, bb 7.12, a new reboot script that handles shutting down buildbot properly.  It is not trivial to remove a bunch of software and expect it to continue working flawlessly.  If we do this, we will get maintenance wins in the long run.  We will of have all of our maemo pool running the same automation code with the same tools which is always good.  This also opens up an option of running unit tests on N810s and Talos on N900s.

Depending on how things go tomorrow (Feb 26 2010) I will look at doing this tomorrow afternoon.
Attached patch sd6 toolsSplinter Review
nuking production-flash
production-sd -> n810-imaging
updating buildbot startup script to set performance + screen dimming

So sd6 does everything except twistd/buildbot/hg/cvs + full redo from scratch, which I'll leave for sd7 or later.
Assignee: jhford → aki
Status: NEW → ASSIGNED
Attachment #429880 - Flags: review?(jhford)
Comment on attachment 429880 [details] [diff] [review]
sd6 tools

wow, i could hardly get past *major* issue on line 178.  I am going to chance it that it will work anyway :P
Attachment #429880 - Flags: review?(jhford) → review+
After 4 failed attempts at imaging SD-v5 onto an SD card to create SD-v6, we're starting from scratch + wiki page. =P
Blocks: 550945
Blocks: 551315
I was able to grab an SD-v5 off of a good n810 (maemo-n810-37 was the greenest one we had).  The recently imaged sd5 n810s look good as well, so we're back in business.  Dropping this bug and continuing rollout of sd5 in bug 544982; we can revisit sd6 (or 7, since I tried+failed on an sd6) when we want to make improvements.
Assignee: aki → nobody
Status: ASSIGNED → NEW
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551315
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.