When reopening a Resolved Duplicated bug in IE, JS error stops the correct page behavior

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
User Interface
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Liya, Assigned: Guy Pyrzak)

Tracking

3.4.4
Bugzilla 3.4
Bug Flags:
approval +
approval3.6 +
blocking3.6 +
approval3.4 +
blocking3.4.6 +

Details

Attachments

(2 attachments)

92.76 KB, image/tiff
Details
747 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6
Build Identifier: 

Reproducible in IE7 and IE8, didn't try older ones
Can not be reproduced in FF at all (no errors in the error console)

Looks like the problem comes from field.js - fails to hide the "dupl" items - see the attached screenshot of the error

Reproducible: Always

Steps to Reproduce:
1. Open a bug in status RESOLVED DUPLICATED in IE
2. Change status to REOPENED


Actual Results:  
JS error appears
(Reporter)

Comment 1

8 years ago
Created attachment 427397 [details]
JS error
(Assignee)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
(Assignee)

Comment 2

8 years ago
Created attachment 427415 [details] [diff] [review]
patch v1
Attachment #427415 - Flags: review?(mkanat)
Attachment #427415 - Flags: review?(LpSolit)

Comment 3

8 years ago
Comment on attachment 427415 [details] [diff] [review]
patch v1

Why would dup_id itself specifically have the bz_default_hidden class on it?
(Assignee)

Comment 4

8 years ago
Comment on attachment 427415 [details] [diff] [review]
patch v1

nevermind. It looks like this will fix one of many errors that happen with IE and the dup stuff. I'll continue working this though
Attachment #427415 - Attachment is obsolete: true
Attachment #427415 - Flags: review?(mkanat)
Attachment #427415 - Flags: review?(LpSolit)
(Assignee)

Comment 5

8 years ago
Comment on attachment 427415 [details] [diff] [review]
patch v1

nevermind. That patch did work perfectly.
Attachment #427415 - Attachment is obsolete: false
Attachment #427415 - Flags: review?(mkanat)
(Reporter)

Updated

8 years ago
Version: unspecified → 3.4.4
(Assignee)

Comment 6

8 years ago
it is added by the line

hideEditableField( "dup_id_container", "dup_id", 'dup_id_edit_action',
                     'dup_id', '2' )

which is part of the template code.

Comment 7

8 years ago
Comment on attachment 427415 [details] [diff] [review]
patch v1

Ah, okay. This looks OK, then. But shouldn't this script actually just be unhiding that directly? Perhaps I don't understand something or I'm just not looking at something.
Attachment #427415 - Flags: review?(mkanat) → review+

Updated

8 years ago
Flags: approval3.6+
Flags: approval3.4+
Flags: approval+
Target Milestone: --- → Bugzilla 3.4

Updated

8 years ago
Assignee: ui → guy.pyrzak
Status: NEW → ASSIGNED

Updated

8 years ago
Flags: blocking3.6+
Flags: blocking3.4.6+
(Assignee)

Comment 8

8 years ago
so what's happening (it does this in firefox too) is that the function (showDuplicateItem) gets called too often it seems. 

The first time the function gets called the value is set to "resolved" but since no one has clicked edit the input box is hidden (behind the edit text). The next time the function (showDuplicateItem) is called the value is updated to the current value and all is happy.

The problem with IE7 and 8 is since the function call errors out it never gets to the 2nd call and then the whole thing gets foobared.

Comment 9

8 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified js/field.js
Committed revision 7005.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified js/field.js
Committed revision 6983.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.4/
modified js/field.js
Committed revision 6728.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.