Projects page search widgets are misaligned

RESOLVED FIXED

Status

Websites Graveyard
www.drumbeat.org
--
critical
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: gerv, Assigned: Campbell Vertesi)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
There is ugliness on https://drumbeat.stage.mozilla.com/projects . The three search widgets (box, dropdown, button) are below and to the right of each other, when I would expect them to be in a line.

Browser: Firefox 3.6 on Ubuntu Linux 9.10.

Gerv

Comment 1

8 years ago
This looks to have been resolved?
(Reporter)

Comment 2

8 years ago
Created attachment 428238 [details]
Misaligned fields

This is what I see on that page when not logged in (Firefox 3.6, Ubuntu 9.10). 

When I log in as gerv, the dropdown changes to <Any> but the misalignment is still there.

When logged in as admin, the problem goes away. I instead see a search box and attached button, the dropdown and a View All Projects link, all in a line.

Gerv

Comment 3

8 years ago
I just confirmed that this is still a problem for anonymous users. See Gerv's screen grab -- just produced the same result. Ugliness indeed.

Updated

8 years ago
Severity: normal → critical

Comment 4

8 years ago
Note: page displays correctly when logged in as admin.

Updated

8 years ago
Assignee: nobody → vertesi
(Assignee)

Comment 5

8 years ago
Flushed the cache, and it's fixed for me.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
this is not resolved
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 7

8 years ago
This is clearly an intermittent bug. Next time someone sees it, they should do a Save Page As... (whole page) and see if they can capture the problem on disk. Then we can compare it with the working version to try and track the problem down.

Gerv

Comment 8

8 years ago
This is fixed in svn.

Some styling wasn't being included on cached pages.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

8 years ago
Mike: please can you attach patches to bugs you fix, as per
https://wiki.mozilla.org/Drumbeat/Website/Hacking
? Thanks :-)

I've svn updated the staging server. There was one change in 
sites/all/themes/drumbeat/css/style.css - presumably that's it?

Gerv

Comment 10

8 years ago
Created attachment 430609 [details] [diff] [review]
Patch from svn commit

Comment 11

8 years ago
My apologies - didn't know that was procedure.
Is referencing the commit revision acceptable also?

Michael
(Reporter)

Comment 12

8 years ago
Mike: no problem. Attaching the patch would generally be part of the review process; we aren't quite there yet with that, but it's good to start. 

Referencing the commit revision in the comment when you RESOLVE the bug is also good practice :-) I'll add that to the page.

Gerv

Comment 13

8 years ago
No problem... we're using redmine, which is nice for the tight svn integration. You can reference tickets in your commit and the commit messages get displayed with the ticket. Likewise you can reverse reference too using the syntax below which will turn into a link to the revision changes in web gui. (I don't think it would scale... but hey :) )

See r63709 & r63710

Comment 14

8 years ago
This issue reoccurred for me when logged in as an authenticated user. Mar 8 5pm EST. Screen grab attached.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

8 years ago
Created attachment 431197 [details]
search widgets misaligned
(Assignee)

Comment 16

8 years ago
Looked at this today, confirmed that on live the projects page is borked for anonymous.  It works on staging however, and we confirmed that the CSS is different on the two sites.

Please SVN update on live server, clear caches and confirm if the problem is still there.
(Reporter)

Comment 17

8 years ago
campbell: live server svn updates every 15 minutes from the "production" tag. mhaggerty is coordinating the moving of that tag. He's your man :-)

Gerv

Comment 18

8 years ago
Appears fixed.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.