If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

splash screen thread never exits

VERIFIED DUPLICATE of bug 65974

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 65974
17 years ago
13 years ago

People

(Reporter: Chris Waterson, Assigned: Bill Law)

Tracking

({footprint})

Trunk
Future
x86
Windows 2000
footprint

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Just did a quantify run, and I noticed that the splash screen thread never
exits. It just hangs around in a wait state until the app terminates. This isn't
a big deal, but it's sloppy, and'll waste a bit of memory.
(Reporter)

Updated

17 years ago
Keywords: footprint

Comment 1

17 years ago
Yep, that IS wasteful.  Bu let's fix it later.
Assignee: don → law
Target Milestone: --- → Future

Comment 2

17 years ago
see bug 54716 (same bug for OS/2, fixed)

Comment 3

17 years ago
nav triage team:

Not a beta1 stopper, marking nsbeta1-
Keywords: nsbeta1-

Comment 4

16 years ago
Is this fixed yet?  I don't know how to test it or I'd check it myself.

Updated

16 years ago
Keywords: mozilla1.0, mozilla1.0.1, nsbeta1

Comment 5

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
How much memory does this waste?
timeless mentioned in irc that this bug appears fixed by bug 65974.
 
On IRC:
<timeless> netlinux: prior to that code, foo::Hide() called
<w32api>::EndDialog() which left the thread alive
<timeless> now foo::Hide() posts a message which the thread catches. the thread
kills the dialog and then appears to die

Comment 8

16 years ago
anybody able to test this ?

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 65974 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.