Last Comment Bug 547260 - Firefox should support CSS styling for Scrollbars.
: Firefox should support CSS styling for Scrollbars.
Status: RESOLVED DUPLICATE of bug 77790
[evang-wanted] [parity-webkit]
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- enhancement with 8 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 08:57 PST by Jan Gerber
Modified: 2016-09-07 03:41 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jan Gerber 2010-02-19 08:57:43 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a2pre) Gecko/20100214 Minefield/3.7a2pre
Build Identifier: 

Here a link to how this works in Webkit:
 http://webkit.org/blog/363/styling-scrollbars/

With rich web apps this becomes more and more important since reimplementing all the scrollbar functionality in javascript is hard and many will fail to implement all functionality. on top of that its ugly. having css styles for scrollbars is much cleaner. 

Reproducible: Always
Comment 1 Jan Gerber 2010-02-19 09:06:52 PST
here is an example of using scrollbars in ui widgets:
 http://oil21.org/~j/tmp/oxjs/_dev/demos/ui/
Comment 2 Robert Longson 2010-02-19 09:15:41 PST
This is bug 77790 isn't it?
Comment 3 Jan Gerber 2010-02-20 01:32:22 PST
Post about how Mozilla Bespin needs custom scrollbars:

http://almaer.com/blog/creating-custom-scrollbars-with-css-how-css-isnt-great-for-every-task

"That being said, at least we do have the ability to do this kind of thing now. I hope that other browsers follow WebKit in this instance."
Comment 4 Daniel.S 2010-12-28 04:43:02 PST

*** This bug has been marked as a duplicate of bug 77790 ***

Note You need to log in before you can comment on or make changes to this bug.