Assertion: NS_ENSURE_TRUE(mSessionHistory) failed

VERIFIED FIXED in mozilla0.9

Status

()

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: jesup, Assigned: radha)

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
FreeBSD 4.1 20000928xx

At the site above (and various pages within it), you get this assertion. This
might be a docshell thing, perhaps.  It's trying to get the history length
attribute from JS when this assertion kicks out.  The JS is at
http://www.avp.ee/Est/menu.html

I don't know if this breaks the JS code, but I wouldn't be surprised.

Backtrace/structure dump attached.
(Reporter)

Comment 1

18 years ago
Created attachment 15863 [details]
backtrace/dump
It looks like  the history object is going to the wrong place in search of 
length.  It should be going to nsHistory.cpp  and calling in to docshell for 
history length. Instead it is calling nsJSHistory.cpp, which looks like is still 
hooked to  nsWebShell's history object which is obsolete. cc'ing nisheeth, 
rpotts
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
Created attachment 19420 [details] [diff] [review]
patch to nsHistory.cpp
I have attached a patch that reroutes all history calls thro' Session History. I
don't see the assertion with the new change. Shall try to get a review soon.

Comment 5

18 years ago
r=rpotts

Hey radha,
If I understand the patch correctly, it directs all of the javascript SH calls
through nsISHistory rather than calling the DocShell (which could be a frame -
without a SH instance)...

Sounds good to me :-)
Rick,
You understood it right. Also it ties all history related queries that comes
from JS to SH. No more frame specific history navigations. Thanks,
Fix checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.