Mail Printing failed in Netscape 6.0.

VERIFIED FIXED

Status

MailNews Core
Printing
P3
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Shirley Liu, Assigned: waqar)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-]suntrak-n6-highp)

(Reporter)

Description

18 years ago
In Netscape 6.0 build id = 2000091312  for Sparc Solaris 2.8.

1. Logged into Mail System.
2. Opened a folder and selected a mail for printing.
3. Clicked Mail Toolbar "Print" button.
4. Browser was kicked out with debug messages: 
"imap_message://sl116442@ha3mpk-mail.eng.sun.com/INBOX#325

PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
top 0.500000 bottom 0.000000 left 0.500000 right 0.000000

PreWidth = 8.500000 PreHeight = 11.000000

Width = 612 Height = 792
dpi 72.000000 top 36 bottom 0 left 36 right 0
Bus Error "

User should be able to print a mail.
(Reporter)

Comment 1

18 years ago
I tried Netscape 6.0 build id=2000100410 for Intel Solaris 2.8.
When printing, browser has been kicked out with debug message:
Width = 612 Height = 792
dpi 72.000000 top 36 bottom 0 left 36 right 0
Enabling Quirk StyleSheet
sh: lpr: not found
nsWidget::~nsWidget() of toplevel: 37 widgets still exist.
WEBSHELL- = 8
Segmentation Fault

Comment 2

18 years ago
It looks like there is no default printer for that last try.
(Reporter)

Comment 3

18 years ago
I tried printing a mail by issuing command "lpr -P printer_name" in netscape 6.0
build id = 2000100317 with Sparc Solaris 2.8.
The mail has been printed well but the browser hs been kicked out with the
following debug messnsWidget::~nsWidget() of toplevel: 47 widgets still exist.
WEBSHELL- = 9

PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
top 0.500000 bottom 0.000000 left 0.500000 right 0.000000

PreWidth = 8.500000 PreHeight = 11.000000

Width = 612 Height = 792
dpi 72.000000 top 36 bottom 0 left 36 right 0
Enabling Quirk StyleSheet
nsWidget::~nsWidget() of toplevel: 44 widgets still exist.
WEBSHELL- = 8

[1]    Done                 ./netscape
Warning: Cannot allocate colormap entry for "#c0c0c0"
Warning:
  Cannot parse default background color spec



(Reporter)

Comment 4

18 years ago
The browser has been kicked out when printing to a printer/ file/ cancel the
printing/ close the print dialog.

Updated

18 years ago
Whiteboard: suntrak-n6-highp
(Reporter)

Comment 5

18 years ago
An unnecessary text printing frame came along with the printing dialog when
printing a mail in netscape 6.0.

Comment 6

18 years ago
Confirmed. Firstly, the print program on Solaris in "lp" and
not "lpr". This means that we are going to have to modify:
.../defaults/pref/unix.js to set the correct print command:
pref("print.print_command", "lp");

Secondly, as Shirley reports, this prints out the mail message
but Mozilla dumps core in the attempt. I only have an optimized
build at the moment, but here is the stack trace:

(gdb) where
#0  0xfcaf9d90 in nsHTMLIFrameElement::HandleChromeEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#1  0xfe141ab0 in GlobalWindowImpl::HandleDOMEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/./libjsdom.so
#2  0xfccb4b40 in nsDocument::HandleDOMEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#3  0xfccceccc in nsGenericElement::HandleDOMEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#4  0xfcaf7aa0 in nsHTMLHtmlElement::HandleDOMEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#5  0xfcaa999c in PresShell::ProcessReflowCommands ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#6  0xfcaa95f4 in PresShell::HandleDOMEventWithTarget ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libgklayout.so
#7  0xff29501c in PL_HandleEvent ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/./libxpcom.so
#8  0xff2947d8 in PL_ProcessPendingEvents ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/./libxpcom.so
#9  0xff2959f0 in nsEventQueueImpl::ProcessPendingEvents ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/./libxpcom.so
#10 0xfda218bc in nsAppShell::SetDispatchListener ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libwidget_gtk.so
#11 0xfda21650 in nsAppShell::ListenToEventQueue ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libwidget_gtk.so
#12 0xfd7c42a4 in g_io_unix_dispatch ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/../dist/lib/libglib-1.2.so.0
#13 0xfd7c5d10 in g_main_dispatch ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/../dist/lib/libglib-1.2.so.0
#14 0xfd7c65b0 in g_main_iterate ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/../dist/lib/libglib-1.2.so.0
#15 0xfd7c6ed8 in g_main_run ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/../dist/lib/libglib-1.2.so.0
#16 0xfd8cb44c in gtk_main ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/../dist/lib/libgtk-1.2.so.0
#17 0xfda21960 in nsAppShell::Run ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libwidget_gtk.so
#18 0xfe09c07c in nsAppShellService::Run ()
   from /spare/MOZ-BUILDS/101200-sunapps/package/components/libnsappshell.so
#19 0x16644 in CheckForNewChrome ()
#20 0x16a8c in main ()

I'm in the process of recompiling Mozilla with debug to get more
useful debugging information.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
Confirming that this is happening on Solaris x86 (8) also.

Comment 8

18 years ago
It fails in the same way when printing to a file, rather than the
line printer. The contents of the file are fine though.

Comment 9

18 years ago
added crash and rtm keywords. Can anybody try on Linux?
Keywords: crash, rtm

Comment 10

18 years ago
I have not a clue to why this is crashing.. can you help with this since I don't 
have any idea how to track this down.
Assignee: dcone → syd

Comment 11

18 years ago
I've just tried a build of the Mozilla trunk from a couple of days ago,
and do not see the crash. The crash occurs in builds generated with the
-r Netscape_20000922_BRANCH -D "10/29/00 10:00:00" tag; the one we are
using to generate our Netscape 6 PR3 release.

I'm going to pull tip-of-the-tree Mozilla now, and see if the problem
is still present.

Comment 12

18 years ago
My PR3 debug build has finished, so I tried printing a mail message again.
Here's the debug stack trace:

(gdb) where
where
#0  0x5c050 in _end ()
#1  0xfbc5badc in nsHTMLIFrameElement::QueryInterface (this=0xd68f30,
aIID=@0xfc7c5734, aInstancePtr=0xffbee644) at nsHTMLIFrameElement.cpp:123
#2  0xff10d71c in nsQueryInterface::operator() (this=0xffbee728,
aIID=@0xfc7c5734, answer=0xffbee644) at nsCOMPtr.cpp:32
#3  0xfc6368a0 in ?? () at ../../../dist/include/nsILayoutHistoryState.h:16 from
/spare/ws/mozilla/mozilla-sparc-nightly/mozilla/dist/bin/components/libgklayout.so
#4  0xfc637f38 in ?? () at ../../../dist/include/nsILayoutHistoryState.h:16 from
/spare/ws/mozilla/mozilla-sparc-nightly/mozilla/dist/bin/components/libgklayout.so
#5  0xfc637c98 in ?? () at ../../../dist/include/nsILayoutHistoryState.h:16 from
/spare/ws/mozilla/mozilla-sparc-nightly/mozilla/dist/bin/components/libgklayout.so
#6  0xfb737da4 in ?? () at ../../../dist/include/nsAWritableString.h:838 from
/spare/ws/mozilla/mozilla-sparc-nightly/mozilla/dist/bin/./libjsdom.so
#7  0xfb49c210 in GlobalWindowImpl::HandleDOMEvent (this=0xd95458,
aPresContext=0xdb62c8, aEvent=0xd9ede0, aDOMEvent=0xffbeea8c, aFlags=4,
aEventStatus=0xffbeeb80) at nsGlobalWindow.cpp:465
#8  0xfbf4a918 in nsDocument::HandleDOMEvent (this=0xd7efb8,
aPresContext=0xdb62c8, aEvent=0xd9ede0, aDOMEvent=0xffbeea8c, aFlags=4,
aEventStatus=0xffbeeb80) at nsDocument.cpp:3038
#9  0xfbf7ff5c in nsGenericElement::HandleDOMEvent (this=0xd80eb4,
aPresContext=0xdb62c8, aEvent=0xd9ede0, aDOMEvent=0xffbeea8c, aFlags=1,
aEventStatus=0xffbeeb80) at nsGenericElement.cpp:1387
#10 0xfbc59368 in nsHTMLHtmlElement::HandleDOMEvent (this=0xd80ea0,
aPresContext=0xdb62c8, aEvent=0xd9ede0, aDOMEvent=0x0, aFlags=1,
aEventStatus=0xffbeeb80) at nsHTMLHtmlElement.cpp:185
#11 0xfbbcf77c in PresShell::HandlePostedDOMEvents (this=0xda9d58) at
nsPresShell.cpp:3523
#12 0xfbbd2ffc in PresShell::ProcessReflowCommands (this=0xda9d58,
aInterruptible=1) at nsPresShell.cpp:4550
#13 0xfc59252c in ?? () at ../../../dist/include/nsHashtable.h:229 from
/spare/ws/mozilla/mozilla-sparc-nightly/mozilla/dist/bin/components/libgklayout.so
#14 0xfbbd2574 in HandlePLEvent (aEvent=0xdd5e90) at nsPresShell.cpp:4371
#15 0xff0f82f4 in PL_HandleEvent (self=0xdd5e90) at plevent.c:575
#16 0xff0f8020 in PL_ProcessPendingEvents (self=0x621c8) at plevent.c:508
#17 0xff0faacc in nsEventQueueImpl::ProcessPendingEvents (this=0x62198) at
nsEventQueue.cpp:356
#18 0xfcb44b3c in event_processor_callback (data=0x62198, source=5,
condition=GDK_INPUT_READ) at nsAppShell.cpp:158
#19 0xfcb4458c in our_gdk_io_invoke (source=0x31d220, condition=G_IO_IN,
data=0x333540) at nsAppShell.cpp:58
#20 0xfddc42a4 in g_io_unix_dispatch () from
/spare/ws/mozilla/mozilla-sparc-nightly/dist/lib/libglib-1.2.so.0
#21 0xfddc5d10 in g_main_dispatch () from
/spare/ws/mozilla/mozilla-sparc-nightly/dist/lib/libglib-1.2.so.0
#22 0xfddc65b0 in g_main_iterate () from
/spare/ws/mozilla/mozilla-sparc-nightly/dist/lib/libglib-1.2.so.0
#23 0xfddc6ed8 in g_main_run () from
/spare/ws/mozilla/mozilla-sparc-nightly/dist/lib/libglib-1.2.so.0
#24 0xfdecb44c in gtk_main () from
/spare/ws/mozilla/mozilla-sparc-nightly/dist/lib/libgtk-1.2.so.0
#25 0xfcb454cc in nsAppShell::Run (this=0x201fa8) at nsAppShell.cpp:335
#26 0xfab473f0 in nsAppShellService::Run (this=0x21f838) at
nsAppShellService.cpp:407
#27 0x235dc in main1 (argc=1, argv=0xffbef5ec, nativeApp=0x0) at
nsAppRunner.cpp:1004
#28 0x23fd8 in main (argc=1, argv=0xffbef5ec) at nsAppRunner.cpp:1185
(gdb) 

I'm currently pulling/build tip-of-the-tree, and will report my finding
there.

Comment 13

18 years ago
I've just tried this with tip-of-the-trunk Mozilla, on my Solaris
SPARC machine, and mail messages print fine. Marking as WORKSFORME. 
Toshi, can you verify this please. Thanks.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
Just wanted to add that using Mozilla tip-of-the-RTM branch built 
from last night, I no longer see this problem either. Looks like
something changed after PR3 to fix this crash.

Comment 15

18 years ago
Using build 2000101802, this problem still exist in netscape 6. After printing,
it gave me a "segmentation fault - core dump" error.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 16

18 years ago
Rich,

I'm testing with PR3 builds for solaris and I still see this problem.  Can
we have the fix backported for our (solaris) PR3 release? Right now printing on
solaris for PR3 is broken..

-raghu

Comment 17

18 years ago
Reassigning to kevin for triage
Assignee: syd → kmcclusk
Status: REOPENED → NEW
Marking WORKSFORME since it doesn't crash on the RTM tip anymore.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

18 years ago
I tried the final test blitz,mail printing still not working even there was no
crash.
1. Printed a mail, an unnecessary print frame still showed up with the print dialog.
2. the mail has not been printed, error message as follows,
ld.so.1: lpr: fatal: libXm.so: open failed: No such file or directory
Killed
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 20

18 years ago
I just tried with 10/31 bits myself, although my print preference is to print to
file.  That worked fine.

I also just tried printing directly to a printer; it worked for me.

Build info: Mozilla/5.0 (X11; U; SunOS 5.7 sun4u; en-US; m18) Gecko/20001030
Netscape6/6.0
Reassigning to waqar.
Assignee: kmcclusk → waqar
Status: REOPENED → NEW
Marking rtm-.
Summary: Mail Printing failed in Netscape 6.0. → [rtm-]Mail Printing failed in Netscape 6.0.
Putting rtm- in status.
Summary: [rtm-]Mail Printing failed in Netscape 6.0. → Mail Printing failed in Netscape 6.0.
Whiteboard: suntrak-n6-highp → [rtm-]suntrak-n6-highp

Comment 24

18 years ago
Talked to Shirley. She will open another bug to track the "unnecessary" print
frame and the error message. We can consider this bug as closed as printing has
been verified to work on solaris platform. I will close this bug.

thx
-raghu
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
Since it has been verified Solaris, And this is working in the RTM builds too.
Linux (2000-11-08-07 MN6)
Win32 (2000-11-08-01 MN6)
Mac (2000-11-08-00 MN6)
Closing this bug for.
Status: RESOLVED → VERIFIED
QA Contact: esther → fenella
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.