Close the "Page Source dialog", crash

VERIFIED DUPLICATE of bug 53953

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 53953
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Branch build 2000-09-28-09MN6: NT4

Overview: With my start page I look at the Page Source (via the menu or Ctrl+U) 
then close the dialog by selecting the 'x' and a crash occurs.

There should be a talkback report but I can't see the incident information right 
now. Seth reproduced the problem and has a stack trace.
(Reporter)

Updated

18 years ago
Keywords: crash
I was able to reproduce this no problem.

the "view source" was done on a specific local html page.  (file://)

I'll attach that page next.

here's the stack trace:

nsBrowserInstance::ReinitializeContentVariables() line 475 + 39 bytes
nsBrowserInstance::GetContentAreaDocShell(nsIDocShell * * 0x0012f118) line 497
nsBrowserInstance::Close(nsBrowserInstance * const 0x03dba400) line 1496 + 32 
bytes
nsBrowserInstance::~nsBrowserInstance() line 460
nsBrowserInstance::`scalar deleting destructor'() + 15 bytes
nsBrowserInstance::Release(nsBrowserInstance * const 0x03dba400) line 563 + 158 
bytes
nsXPCWrappedNative::~nsXPCWrappedNative() line 398 + 27 bytes
nsXPCWrappedNative::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPCWrappedNative::Release(nsXPCWrappedNative * const 0x03dba3a0) line 71 + 31 
bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x038fea70, JSObject * 
0x03092ac8) line 96
WrappedNative_Finalize(JSContext * 0x038fea70, JSObject * 0x03092ac8) line 783
js_FinalizeObject(JSContext * 0x038fea70, JSObject * 0x03092ac8) line 1600 + 114 
bytes
gc_finalize_phase(JSContext * 0x038fea70, unsigned int 113) line 907 + 11 bytes
js_GC(JSContext * 0x038fea70, unsigned int 0) line 1173 + 13 bytes
js_ForceGC(JSContext * 0x038fea70) line 871 + 11 bytes
js_DestroyContext(JSContext * 0x038fea70, int 2) line 219 + 9 bytes
JS_DestroyContext(JSContext * 0x038fea70) line 832 + 11 bytes
nsJSContext::~nsJSContext() line 366 + 13 bytes
nsJSContext::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsJSContext::Release(nsJSContext * const 0x038e7080) line 374 + 154 bytes
nsCOMPtr<nsIScriptContext>::assign_assuming_AddRef(nsIScriptContext * 
0x00000000) line 472
nsCOMPtr<nsIScriptContext>::assign_with_AddRef(nsISupports * 0x00000000) line 
849
nsCOMPtr<nsIScriptContext>::operator=(nsIScriptContext * 0x00000000) line 584
nsDocShell::Destroy(nsDocShell * const 0x03c981c4) line 1614
nsWebShell::Destroy(nsWebShell * const 0x03c981c4) line 1393
nsXULWindow::Destroy(nsXULWindow * const 0x03c79bd4) line 324
nsWebShellWindow::Destroy(nsWebShellWindow * const 0x03c79bd4) line 1779
nsWebShellWindow::Close(nsWebShellWindow * const 0x03c79c30) line 368
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012f63c) line 447
nsWindow::DispatchEvent(nsWindow * const 0x03c78d74, nsGUIEvent * 0x0012f63c, 
nsEventStatus & nsEventStatus_eIgnore) line 681 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f63c) line 702
nsWindow::DispatchStandardEvent(unsigned int 101) line 722 + 15 bytes
nsWindow::ProcessMessage(unsigned int 16, unsigned int 0, long 0, long * 
0x0012f974) line 2795
nsWindow::WindowProc(HWND__ * 0x12de01d4, unsigned int 16, unsigned int 0, long 
0) line 950 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e718d2()
nsWindow::DefaultWindowProc(HWND__ * 0x12de01d4, unsigned int 274, unsigned int 
61536, long 1246032) line 977
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x12de01d4, unsigned int 274, unsigned int 61536, 
long 1246032) line 957 + 31 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e718d2()
nsWindow::DefaultWindowProc(HWND__ * 0x12de01d4, unsigned int 161, unsigned int 
20, long 1246032) line 977
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x12de01d4, unsigned int 161, unsigned int 20, 
long 1246032) line 957 + 31 bytes
USER32! 77e71820()
00130350()
Summary: Close the Page Source dialog, crash → Close the "Page Source dialog", crash
Created attachment 15873 [details]
the page that causes the crash

Comment 3

18 years ago
dup of bug 53953, stack trace confirms...

*** This bug has been marked as a duplicate of 53953 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.