Status

()

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: duncan.loveday, Assigned: longsonr)

Tracking

({regression, testcase})

unspecified
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 2.0.50727)

In the attached, the function zoomHandler() named in the SVG onzoom attribute is not called when currentScale is changed (worked on 3.5.x)

Reproducible: Always

Steps to Reproduce:
1. Open the html attachment and click the button
2.
3.
Actual Results:  
Two alerts are shown, one when the SVG is loaded and another when the onclick handler for the button is called.

Expected Results:  
A total of three alerts should be shown, the two described above and another when the onzoom handler for the SVG is called.
Posted image Test SVG (obsolete) —
Posted file Test html (obsolete) —
Keywords: regression, testcase
Attachment #428088 - Attachment is obsolete: true
Attachment #428090 - Attachment is obsolete: true
If it's a regression do you fancy getting a regression range?
Yes I can do that.

Renesis plugin has the same behaviour BTW - no chance it's an intentional change is there ?
Never mind. I don't need a regression range any more. The issue is obvious enough.
It's not an intentional change.
Posted patch patchSplinter Review
Assignee: nobody → longsonr
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #428095 - Flags: review?(roc)
Comment on attachment 428095 [details] [diff] [review]
patch

r=jwatt
Attachment #428095 - Flags: review?(roc) → review+
This is quick work !

BTW is it safe to assume this fix WON'T be released until 3.7.x ?

I can code round it but calling the zoom handler explicitly but that'll break if the behaviour changes in a minor update
Blocks: 474230
3.7 hasn't been released. Do you mean 3.6.x? This patch will probably be in the former, but won't be in the latter.
Yes, that's what I meant - patch won't be in a minor update for 3.6.x. I'll code up a bit of nasty user agent sniffing for 3.6 (but not 3.7).

Thanks Jonathan
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.