[HTML5] toolkit/content/tests/widgets/test_radio.xul fails

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
P1
normal
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
150311 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_radio.xul | accesskey focuses radiogroup - got [object XULElement], expected [object XULElement]
150312 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_radio.xul | accesskey selects radio - got [object XULElement], expected [object XULElement]
150314 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_radio.xul | accesskey on disabled radio doesn't change selection - got [object XULElement], expected [object XULElement]
(Reporter)

Comment 1

8 years ago
I don't see any connection to the HTML5 parser here.
(Reporter)

Comment 2

8 years ago
This could be random and cross-platform.
OS: Windows XP → All
(Reporter)

Comment 3

8 years ago
WFM on Mac and Linux x86_64.
Summary: [HTML5] toolkit/content/tests/widgets/test_radio.xul fails → [HTML5][WFM?] toolkit/content/tests/widgets/test_radio.xul fails
(Reporter)

Comment 4

8 years ago
Fails on Windows tryserver still.
OS: All → Windows XP
Summary: [HTML5][WFM?] toolkit/content/tests/widgets/test_radio.xul fails → [HTML5] toolkit/content/tests/widgets/test_radio.xul fails
(Reporter)

Comment 5

8 years ago
This test case fails with html5.enable=true on Windows tryserver. The failure messages aren't helpful (got [object XULElement], expected [object XULElement]). I don't see any connection to the HTML parser.

Do you have ideas on how this could depend on the HTML parser?

Comment 6

8 years ago
Does setting html5.enable=true cause different tests to run beforehand?
(Reporter)

Comment 7

8 years ago
The set of tests is the same, but the following tests have some pref-sensitivity:
/content/base/test/test_bug527896.html
/content/base/test/test_bug503473.html
/parser/htmlparser/tests/mochitest/test_bug502091.html
/parser/htmlparser/tests/mochitest/test_compatmode.html
(Reporter)

Comment 8

8 years ago
For the test run, I had disabled these tests:
http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/ajax/offline/test_foreign.html?force=1
http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/ajax/offline/test_updatingManifest.html?force=1
http://mxr.mozilla.org/mozilla-central/source/parser/htmlparser/tests/mochitest/test_html5_tree_construction.html?force=
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/startup/tests/browser/browser_bug537449.js
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/startup/tests/browser/browser_bug511456.js
(Reporter)

Comment 9

8 years ago
It seems that this failure was caused by bug 546648 and was fixed by the patch for that bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.