If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Split GIO and GConf support into separate modules

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
enhancement
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Matthew Turnbull [Bluefang], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a2pre) Gecko/20100222 Minefield/3.7a2pre Firefox/3.7
Build Identifier: 

I recently switched away from a pure GNOME desktop and I was unhappy to see that MIME and URI scheme handling became broken. After some investigation I found that the libmozgnome module wasn't being loaded because some of the things it linked against were no longer installed (i.e. libgnome, libgnomeui, gnome-vfs).

IMHO both GIO anf GConf should be separated into their own modules so that they can be loaded independently if they are present on the system.

- GIO is provided glib, which is present on any system that has GTK installed, and is in no way tied to GNOME. IMHO this should have never been included in the GNOME module in the first place. Rather, it should be built in its own module if GTK is enabled, and loaded if the necessary glib version is found.

- GConf does originate from GNOME, but it is also used by applications outside of a GNOME environment. For example, XFCE supports starting GConf as part of user sessions. While man of these programs did originate from, or are intended for the GNOME environment, many of them are just GTK applications and are in no way tied to GNOME. If a GConf sessions is available, I don't see any reason why Firefox shouldn't be able to integrate with it.


Reproducible: Always

Comment 1

8 years ago
Seems duplicate of bug #526451
(Reporter)

Comment 2

8 years ago
bug #526451 is about build-time. I'm talking about runtime.

The mozgnome component (containing gnome-vfs/GIO/GConf/Alerts) will not load at runtime unless all of the build time components are present.

When using the Mozilla binary [nightly] builds, this makes it impossible to use GConf/GIO on systems missing gnome-vfs/libgnome[ui]

Since all of the components in mozgnome already look to be split-up and independent of each other, I would think it would be a trivial task of splitting them up into their own individual modules.

Comment 3

8 years ago
Also, note that gnome-vfs and libgnome* libraries are deprecated and won't be shipped with GNOME 3, that will be released in October, 2010
Bug 713827 is another possible solution.
Depends on: 713827
As one bug 713827 (for GConf) and bug 713802 (for GnomeVFS), I don't think there is any need for this now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Depends on: 713802
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.