CSAT responses broken due to hardcoded forumIDs?

VERIFIED FIXED in 1.5.2

Status

support.mozilla.org
Mobile
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: stephend, Assigned: jsocol)

Tracking

unspecified
1.5.2

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
After choosing the "Yes, this solved my problem" link on Mobile's CSAT, I'm taken to, say:

https://mobile-support-stage.mozilla.com/tiki-feedback.php?id=50&hash=49a5ab157d3b8869ab93952e425ad973&type=forum_topic&feedback=Firefox%20Support%20Forum&commentId=51

...but I just get:

Error

Permission denied you cannot view this page

(According to Cheng, this is because we hard-code our Forum IDs?)

Comment 2

8 years ago
Duplicate of bug 547770 ?
(Assignee)

Comment 3

8 years ago
No, bug 547770 caused an error in the JS console but did nothing in the browser.

Updated

8 years ago
Assignee: nobody → laura

Comment 4

8 years ago
BTW I get
This forum is flat and doesn't allow replies to other replies 
frmo your link in comment #1. (Possibly deleted by the new db dump on stage?)

Comment 5

8 years ago
Also, I haven't been able to repro this :(

Updated

8 years ago
Target Milestone: 1.5.2 → 1.5.3

Updated

8 years ago
Severity: critical → normal
(Reporter)

Comment 6

8 years ago
Sorry; full STR:

1. Visit http://mobile-support-stage.mozilla.com/en-US/forum/5
2. Ask a question while logged in (preferably)
3. Click "Watch this topic" at the top right
4. Come along as another user and choose "Proposed solution to the problem"

The original poster (1-2) should now get an email with the "Yes, this solved..." and "No, ..." links.

Clicking on those will yield the error in comment 0.
(Reporter)

Comment 7

8 years ago
(BTW, step 3 shouldn't be necessary for email notification, I don't think -- I thought it should be automatic; is that a config thing, Cheng?)

Updated

8 years ago
Assignee: laura → nobody
(Reporter)

Updated

8 years ago
Target Milestone: 1.5.3 → 1.5.2
(Assignee)

Updated

8 years ago
Assignee: nobody → james
(Assignee)

Comment 8

8 years ago
Created attachment 432913 [details] [diff] [review]
there was some missing data in the tiki_polls and tiki_poll_options tables

It looks like the poll data was hard coded, in a sense, and missing. This adds that data into the tables, and made the thread solutions work for me.
Attachment #432913 - Flags: review?(paulc)
Comment on attachment 432913 [details] [diff] [review]
there was some missing data in the tiki_polls and tiki_poll_options tables

WFM. I understand this was broken when going through the tiki-feedback link, not when viewing the thread itself.

Makes me wonder what other CSAT voting may be broken.
Attachment #432913 - Flags: review?(paulc) → review+
(Assignee)

Updated

8 years ago
Depends on: 553044
(Assignee)

Comment 10

8 years ago
This this is pure SQL, filed bug 553044 to run the patch on mobile-support-stage.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

8 years ago
Verified FIXED; weird that you have to explicitly "Watch this topic," even when you're a logged-in user, but that's a separate (config?) issue.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.