could not make correctly on NetBSD

RESOLVED FIXED

Status

P3
critical
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: taya, Assigned: mhein)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
To compile correctly on NetBSD, some modification needed for GETHOSTNAME() and
CTIME() in include/portable.h
GETHOSTNAME() shouled be gethostname and CTIME() should be ctime_r( c, b )
(Reporter)

Comment 1

18 years ago
Created attachment 15909 [details] [diff] [review]
patch to solve this problem
(Reporter)

Comment 2

18 years ago
Created attachment 15910 [details] [diff] [review]
patch to solve this problem
(Reporter)

Updated

18 years ago
Blocks: 54797

Comment 3

18 years ago
The patch looks okay.  Reassigning to Michael Hein to apply the patch.
Assignee: mcs → mhein
(Reporter)

Comment 4

18 years ago
One month passed since last comment. What is the status of this patch?

Comment 5

18 years ago
Setting correct OS field.
Is someone looking at this patch?
OS: other → NetBSD

Comment 6

18 years ago
Michael, can you apply this patch to the mozilla tree?    It looks okay to me.
(Assignee)

Comment 7

18 years ago
Checkin to 4.0 version:

sorbet > cvs diff -c portable.h
Index: portable.h
===================================================================
RCS file: /cvsroot/mozilla/directory/c-sdk/ldap/include/portable.h,v
retrieving revision 1.2.2.3
diff -c -r1.2.2.3 portable.h
*** portable.h  2000/04/20 16:18:00     1.2.2.3
--- portable.h  2000/11/21 22:51:34
***************
*** 243,249 ****
      defined(UNIXWARE) || defined(SUNOS4) || defined(SNI) || defined(BSDI) || \
      defined(NCR) || defined(OSF1) || defined(NEC) || \
      ( defined(HPUX10) && !defined(_REENTRANT)) || defined(HPUX11) || \
!     defined(UnixWare) || defined(LINUX) || (defined(AIX) && 
!defined(USE_REENTRANT_LIBC))
  #define GETHOSTBYNAME( n, r, b, l, e )  gethostbyname( n )
  #elif defined(AIX)
  /* Maybe this is for another version of AIX?
--- 243,250 ----
      defined(UNIXWARE) || defined(SUNOS4) || defined(SNI) || defined(BSDI) || \
      defined(NCR) || defined(OSF1) || defined(NEC) || \
      ( defined(HPUX10) && !defined(_REENTRANT)) || defined(HPUX11) || \
!     defined(UnixWare) || defined(LINUX) || defined(NETBSD) || \
!     (defined(AIX) && !defined(USE_REENTRANT_LIBC))
  #define GETHOSTBYNAME( n, r, b, l, e )  gethostbyname( n )
  #elif defined(AIX)
  /* Maybe this is for another version of AIX?
***************
*** 273,279 ****
  #elif defined(HPUX10) && defined(_REENTRANT) && !defined(HPUX11)
  #define CTIME( c, b, l )              nsldapi_compat_ctime_r( c, b, l )
  #elif defined( IRIX6_2 ) || defined( IRIX6_3 ) || defined(UNIXWARE) \
!       || defined(OSF1V4) || defined(AIX) || defined(UnixWare) || defined(hpux) 
|| defined(HPUX11)
  #define CTIME( c, b, l )                ctime_r( c, b )
  #elif defined( OSF1V3 )
  #define CTIME( c, b, l )              (ctime_r( c, b, l ) ? NULL : b)
--- 274,280 ----
  #elif defined(HPUX10) && defined(_REENTRANT) && !defined(HPUX11)
  #define CTIME( c, b, l )              nsldapi_compat_ctime_r( c, b, l )
  #elif defined( IRIX6_2 ) || defined( IRIX6_3 ) || defined(UNIXWARE) \
!       || defined(OSF1V4) || defined(AIX) || defined(UnixWare) || defined(hpux) 
|| defined(HPUX11) || defined(NETBSD)
  #define CTIME( c, b, l )                ctime_r( c, b )
  #elif defined( OSF1V3 )
  #define CTIME( c, b, l )              (ctime_r( c, b, l ) ? NULL : b)

Checking in portable.h;
/cvsroot/mozilla/directory/c-sdk/ldap/include/portable.h,v  <--  portable.h
new revision: 1.2.2.4; previous revision: 1.2.2.3
done

Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
*** Bug 61755 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 61755 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

18 years ago
psm(PSM_1_4_N6) worked.
verified.
Thanks!
You need to log in before you can comment on or make changes to this bug.