Closed Bug 548248 Opened 12 years ago Closed 10 years ago

Crash [@ nsGenericElement::cycleCollection::Traverse(void*, nsCycleCollectionTraversalCallback&) ]

Categories

(Core :: General, defect)

1.9.1 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 597344

People

(Reporter: xtc4uall, Unassigned)

Details

(Keywords: crash)

Crash Data

filed on behalf of a Fx user reporting this crash report in the german support forum.

Signature	nsGenericElement::cycleCollection::Traverse(void*, nsCycleCollectionTraversalCallback&)
UUID	7883c6b9-0cb7-4582-85c8-aca942100220
Time 	2010-02-20 16:25:35.135452
Uptime	177753
Last Crash	177768 seconds before submission
Product	Firefox
Version	3.5.7
Build ID	20091221164558
Branch	1.9.1
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x4
User Comments	
Processor Notes

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsGenericElement::cycleCollection::Traverse(void*,nsCycleCollectionTraversalCallback&) 	content/base/src/nsGenericElement.cpp:4076
1 	xul.dll 	xul.dll@0x9c55df 	
2 	xul.dll 	nsCycleCollector::MarkRoots(GCGraphBuilder&) 	xpcom/base/nsCycleCollector.cpp:1571
3 	xul.dll 	nsCycleCollector::BeginCollection() 	xpcom/base/nsCycleCollector.cpp:2467
4 	xul.dll 	XPCCycleCollectGCCallback 	js/src/xpconnect/src/nsXPConnect.cpp:390
5 	js3250.dll 	js_GC 	js/src/jsgc.cpp:3504
6 	js3250.dll 	JS_GC 	js/src/jsapi.cpp:2458
7 	xul.dll 	nsXPConnect::Collect() 	js/src/xpconnect/src/nsXPConnect.cpp:477
8 	xul.dll 	nsCycleCollector::Collect(unsigned int) 	xpcom/base/nsCycleCollector.cpp:2386
9 	xul.dll 	nsCycleCollector_collect() 	xpcom/base/nsCycleCollector.cpp:3045
10 	xul.dll 	nsJSContext::CC() 	dom/src/base/nsJSEnvironment.cpp:3534
11 	xul.dll 	xul.dll@0x33e3f7

digging in crashstats site you can see that all branches are affected:
http://crash-stats.mozilla.com/report/list?product=Firefox&branch=1.9.0&branch=1.9.1&branch=1.9.2&branch=1.9.3&query_search=signature&query_type=contains&query=nsGenericElement%3A%3AcycleCollection%3A%3ATraverse&date=&range_value=1&range_unit=weeks&process_type=all&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&signature=nsGenericElement%3A%3AcycleCollection%3A%3ATraverse%28void*%2C%20nsCycleCollectionTraversalCallback%26%29

Fx 3.6. thread (of bp-1cc1887e-616c-4001-aea4-b751a2100224):
Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsGenericElement::cycleCollection::Traverse(void*,nsCycleCollectionTraversalCallback&) 	content/base/src/nsGenericElement.cpp:4055
1 	xul.dll 	xul.dll@0xa97607 	
2 	xul.dll 	nsCycleCollector::MarkRoots(GCGraphBuilder&) 	xpcom/base/nsCycleCollector.cpp:1611
3 	xul.dll 	nsCycleCollector::BeginCollection() 	xpcom/base/nsCycleCollector.cpp:2554

Fx 3.7a1 thread (of bp-e90433d8-c005-4976-84e3-59a782100223):
Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsGenericElement::cycleCollection::Traverse(void*,nsCycleCollectionTraversalCallback&) 	content/base/src/nsGenericElement.cpp:4046
1 	xul.dll 	nsCycleCollector::MarkRoots(GCGraphBuilder&) 	xpcom/base/nsCycleCollector.cpp:1697
2 	xul.dll 	nsCycleCollector::BeginCollection() 	xpcom/base/nsCycleCollector.cpp:2641
3 	xul.dll 	XPCCycleCollectGCCallback 	js/src/xpconnect/src/nsXPConnect.cpp:392
4 	mozjs.dll 	js_GC 	js/src/jsgc.cpp:3196
5 	mozjs.dll 	JS_GC 	js/src/jsapi.cpp:2464
6 	xul.dll 	nsXPConnect::Collect() 	js/src/xpconnect/src/nsXPConnect.cpp:479
7 	mozcrt19.dll 	free 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6017
8 	xul.dll 	nsCycleCollector::Collect(unsigned int) 	xpcom/base/nsCycleCollector.cpp:2521

above signature is currently listed as Fx3.6 crash #133.
looking at module, extension and comments info points to nothing special.
Crash Signature: [@ nsGenericElement::cycleCollection::Traverse(void*, nsCycleCollectionTraversalCallback&) ]
probably duplicate of bug 597344, which has more info
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597344
You need to log in before you can comment on or make changes to this bug.