Closed Bug 548549 Opened 10 years ago Closed 3 years ago

unify release automation *_info.txt files with the ones generated by the build system

Categories

(Release Engineering :: Release Automation: Other, enhancement, P5)

All
macOS
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Unassigned)

References

Details

(Whiteboard: [automation][triagefollowup])

In bug 474610 Ted added a txt file that contains a buildid that gets uploaded alongside the build. We already do something similar for releases, but it's done in a Buildbot factory. We should support the build system way. The cheap way of doing this is to adjust the path and filename of this file to what the automation expects when MOZ_PKG_PRETTYNAMES is set. Probably the better way is to make the automation support the filenames that the build system already uses.
Yeah, I'm not married to the filename I'm using, it's just the basename of the package file, since that was convenient to use.
Assignee: nobody → jhford
No longer blocks: hg-automation
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: hg-automation
Ben, do you know if we still want this?
It's a "nice to have" for me, I can't think of any reason why we want this other than avoiding duplication.
Duplicate of this bug: 706711
putting back in the pool
Assignee: jhford → nobody
Severity: normal → enhancement
Whiteboard: [automation] → [automation][triagefollowup]
Product: mozilla.org → Release Engineering
Are these still going to exist after we have release promotion? IIRC we talked about possibly passing the buildids via other means, and I don't think these files are used for anything else.
QA Contact: bhearsum
Looks like those are created in ReleaseBuildFactory, so we'll lose them by switching to mozharness. However we can parse files like
 http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64/1435312529/firefox-41.0a1.en-US.linux-x86_64.txt
instead, contents:
20150626025529
https://hg.mozilla.org/mozilla-central/rev/d45440221297
I believe this is fixed and we use info.txt files generated by the build system
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.