"Save link as" redownload the file and does not use the cache

RESOLVED DUPLICATE of bug 530288

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 530288
8 years ago
7 years ago

People

(Reporter: bugzilla_ah@udcast.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8

When saving a file with right clik > "Save link as", the file is not taken from the cache but redownloaded from the web server.

The following options are set in the header of the GET request using "Save link as" :
Pragma: no-cache 
Cache-Control: no-cache

I don't know if this is a "bug" or a "feature" but this is a problem for users with a caching proxy since Firefox forces to reload the content instead of using the cache.


Reproducible: Always

Steps to Reproduce:
Setup using a caching proxy
1. Download a file (PDF, doc, image etc..) with right click on the file then "Save link as ..."
2. Download the same file again with "Save link as"

Actual Results:  
The file is downloaded again from the web server. The GET request contains no-cache options in the header.

Expected Results:  
Retrieve the file from the cache. Download should be faster.

Comment 1

8 years ago
duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=530288

Comment 2

8 years ago
Something in about:config must have been a problem, because a clean install uses cache correctly for me. I found some settings listed in another bug that supposedly were a problem, but changing them did nothing for me.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530288
You need to log in before you can comment on or make changes to this bug.