Closed Bug 548608 Opened 10 years ago Closed 10 years ago

incorrect font fallback behavior for some scripts/languages

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jfkthame, Assigned: jfkthame)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

See bug 524107 comments 34-37: selection of fallback fonts for Chinese-TW and possibly other languages is incorrect since the landing of bug 524107.
Blocks: 524107
Keywords: regression
This was missed in my patch for bug 524107: the Windows override of SupportsLangGroup simply gets ignored because it's not using the updated parameter type.
Assignee: nobody → jfkthame
Attachment #428959 - Flags: review?(roc)
Fixed the patch to actually build properly.
Attachment #428959 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/c2ed18018054
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 548978
The font fallback behavior might not be completely fixed, since some pages in zh-CN still looks bad.  By the way, the font in tab title is always incorrect.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2pre) Gecko/20100226 Minefield/3.7a2pre (.NET CLR 3.5.30729)
(In reply to comment #5)
> The font fallback behavior might not be completely fixed, since some pages in
> zh-CN still looks bad.  By the way, the font in tab title is always incorrect.

If you could provide a specific testcase, along with screenshots of correct and incorrect display, that would be helpful.
No longer depends on: 548978
I have added the screenshots, the upper one is correct.
The test website is http://www.mozillaonline.com/. When in Firefox 3.6 with a clean profile, the tab and bookmark titles display in "Microsoft YaHei" font after setting the default font to the former. But in these days' nightly builds with the same profile, the title displays in some other font.
(In reply to comment #6)
> (In reply to comment #5)
> > The font fallback behavior might not be completely fixed, since some pages in
> > zh-CN still looks bad.  By the way, the font in tab title is always incorrect.
> 
> If you could provide a specific testcase, along with screenshots of correct and
> incorrect display, that would be helpful.

I have uploaded two screenshots of correct (in FF3.6) and incorrect display (in recent FF3.7 nightlies) for the same web page (using the same FF profile).  I have no idea of how to provide a specific test case for this issue.
You need to log in before you can comment on or make changes to this bug.