Closed Bug 548635 Opened 10 years ago Closed 8 years ago

Provide a toolbar button to open the unifinder

Categories

(Calendar :: Lightning Only, enhancement)

All
Windows Vista
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dfghjkjhg, Assigned: Fallen)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 2 obsolete files)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.8) Gecko/20100216 Lightning/1.0b1 Thunderbird/3.0.2

Currently the only way to start a search in Lightning is to choose: Events & Tasks > Find Events.
Would be more convenient to have a button in the Lightning header pane for opening the Lightning search function/box.

Reproducible: Always
Other idea:
Instead of a search button --> provide the Lightning searchbox itself in the Lightning header pane.
Summary: Provide a button in the Lighting header pane for opening the Lightning search function/box → Provide a button in the Lighting header pane for opening the Lightning searchbox (or provide the searchbox itself)
After thinking about this again, I guess the best solution would be to extend Thunderbird's already existing (e-mail-)searchbar also to searches within Lightning.
Doing this, the additional Lightning-searchbar wouldn't be necessary at all any more.
--> Therefore I close this bug and open a new one.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
I would like to reopen this bug, because I just installed TB 3.1 beta 2 and investigated the following:
As now TB's Searchbox disappears when Gloda is deactivated (and the new "quick filter bar" has to be used instead), even if TB's searchbox will become able to search for Lightning calendar items one day (Bug 461032), I cannot use it if I have disabled Gloda (due to the disappearing searchbox).

So again I would need Lightning's Unifinder in Lightnings header pane (preferably in the empty area between "first day of the week" and "CW:...") --> see attached screenshot as an suggestion.

Then (unlike today) unifinder's hitlist only needs to be displayed after executing the search (today the hitlist is already displayed when the unifinder bar opens without having entered anything to search for).
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Provide a button in the Lighting header pane for opening the Lightning searchbox (or provide the searchbox itself) → Provide the Unifinder in Lightning's header pane by standard (or at least provide a button to open the unifinder)
I believe F11 opens the unifinder. I'm confirming for now, although I'm not sure I like seeing multiple textboxes as it is now for the quick filter bar and gloda enabled.

Since the current unifinder search is very basic (no advanced filter stuff), I could maybe imagine a quick search box like in Firefox (above the status bar).
Status: UNCONFIRMED → NEW
Ever confirmed: true
--> Re comment 5: So far I couldn't find any working shortcut/key for opening the unifinder (F11 also doesn't work). But thanks for the tip.

--> Concerning my alternative "button suggestion":
Maybe TB's search icon could also be introduced in Lightning and be used for opening the unifinder.
See attachment "Apply TB's search icon also to Lightning"
Maybe this solution would be the easiest to implement and make further requested amendments from this bug unnecessary.
This would also show continuity between TB and Lightning.
I'm going to use this bug for adding a toolbar button. We will be expanding the search concept and have the other suggestions on our radar.
Assignee: nobody → philipp
Blocks: 728011
Status: NEW → ASSIGNED
Summary: Provide the Unifinder in Lightning's header pane by standard (or at least provide a button to open the unifinder) → Provide a toolbar button to open the unifinder
Attached patch Fix - v1 (obsolete) β€” β€” Splinter Review
Tested on mac, Richard has already tested on Linux and provided the windows part of this patch.

Decathlon, could you also give this one a quick test? I'd like to ensure good coverage here since this will be going down to beta.
Attachment #600985 - Flags: review?(richard.marti)
Attachment #600985 - Flags: feedback?(bv1578)
Attachment #600985 - Flags: approval-calendar-beta+
Attachment #600985 - Flags: approval-calendar-aurora+
> +#calendar-unifinder-button {
> +  list-style-image: url(chrome://messenger/skin/icons/mail-toolbar.png);

Does this work on SeaMonkey?
Hmm not sure. We copied the icon from mail to calendar back when we introduced the magnifier icon, so I guess we should do the same here. Richard, could you take care?
(In reply to Stefan Sitter from comment #10)
> > +#calendar-unifinder-button {
> > +  list-style-image: url(chrome://messenger/skin/icons/mail-toolbar.png);
> 
> Does this work on SeaMonkey?

Philip I assigned you to ask how this is with the toolbar in SM.
> Philip I assigned you to ask how this is with the toolbar in SM.

applying unifinder-button.diff
Hunk #1 FAILED at 102
1 out of 1 hunks FAILED -- saving rejects to file calendar/base/themes/winstripe/win-aero/lightning-toolbar.css.rej
Hunk #1 FAILED at 213
1 out of 1 hunks FAILED -- saving rejects to file calendar/base/themes/winstripe/win-classic/lightning-toolbar.css.rej
patching file calendar/base/themes/winstripe/win-aero/lightning-toolbar.css
patching file calendar/base/themes/winstripe/win-classic/lightning-toolbar.css
Hunk #1 FAILED at 141
1 out of 1 hunks FAILED -- saving rejects to file calendar/lightning/content/lightning-toolbar.xul.rej
Hunk #1 FAILED at 222
1 out of 1 hunks FAILED -- saving rejects to file calendar/lightning/themes/gnomestripe/lightning-toolbar.css.rej
patching file calendar/lightning/content/lightning-toolbar.xul
patching file calendar/lightning/themes/gnomestripe/lightning-toolbar.css
Hunk #1 FAILED at 282
1 out of 1 hunks FAILED -- saving rejects to file calendar/lightning/themes/pinstripe/lightning-toolbar.css.rej
patching file calendar/lightning/themes/pinstripe/lightning-toolbar.css
patch failed to apply
calendar/base/themes/winstripe/win-aero/lightning-toolbar.css
calendar/base/themes/winstripe/win-classic/lightning-toolbar.css
calendar/lightning/content/lightning-toolbar.xul
calendar/lightning/themes/gnomestripe/lightning-toolbar.css
calendar/lightning/themes/pinstripe/lightning-toolbar.css
patch failed, rejects left in working dir
errors during apply, please fix and refresh bug548635unifinder-button.diff
[command returned code 2 Tue Feb 28 23:48:20 2012]
OK, after converting the patch to unix newlines I got it to apply.

>> +#calendar-unifinder-button {
>> +  list-style-image: url(chrome://messenger/skin/icons/mail-toolbar.png);
> Does this work on SeaMonkey?

Well the button shows up but without any image, which is not surprising since we don't have a mail-toolbar.png, and in any case our images are different. Not withstanding this, the patch is working as intended f=me for functionality.

I suggest that you copy all the necessary icons from Thunderbird into the calendar toolbar-aero.png/toolbar.png.
And I didn't mention it previously but the Edit, Delete, and Print images are also missing as expected.
Attached patch Fix which should better work with SM (obsolete) β€” β€” Splinter Review
I'm doing now a review ping pong ;).

Patch with correct line endings.

I added the mail-toolbar icons to the Lightning icons. It should now work with SM. For OSX I added the same checked style the QFB button is using.
Attachment #600985 - Attachment is obsolete: true
Attachment #601319 - Flags: review?(philipp)
Attachment #601319 - Flags: feedback?(philip.chee)
Attachment #601319 - Flags: feedback?(bv1578)
Attachment #600985 - Flags: review?(richard.marti)
Attachment #600985 - Flags: feedback?(bv1578)
applying bug548635unifinder-button.diff
'calendar/base/themes/winstripe/images/toolbar-aero.png\r'
calendar/base/themes/winstripe/images/toolbar-aero.png
calendar/base/themes/winstripe/win-aero/lightning-toolbar.css
calendar/base/themes/winstripe/win-classic/lightning-toolbar.css
calendar/lightning/content/lightning-toolbar.xul
calendar/lightning/themes/gnomestripe/lightning-toolbar.css
calendar/lightning/themes/pinstripe/lightning-toolbar.css
patch failed, rejects left in working dir
errors during apply, please fix and refresh bug548635unifinder-button.diff
[command returned code 2 Wed Feb 29 11:44:52 2012]
Applies after converting new lines to unix format.
Now really with correct line ending
Attachment #601319 - Attachment is obsolete: true
Attachment #601522 - Flags: review?(philipp)
Attachment #601522 - Flags: feedback?(philip.chee)
Attachment #601522 - Flags: feedback?(bv1578)
Attachment #601319 - Flags: review?(philipp)
Attachment #601319 - Flags: feedback?(philip.chee)
Attachment #601319 - Flags: feedback?(bv1578)
Comment on attachment 601522 [details] [diff] [review]
Fix which should better work with SM

This patch works. All the buttons on the Lightning toolbars show images. f=me
Attachment #601522 - Flags: feedback?(philip.chee) → feedback+
Comment on attachment 601522 [details] [diff] [review]
Fix which should better work with SM

Review of attachment 601522 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp with below comment considered. Please push to aurora and beta too.

::: calendar/lightning/themes/pinstripe/lightning-toolbar.css
@@ +318,5 @@
> +  border-color: transparent;
> +  border-radius: 4px;
> +  box-shadow: 0 1px rgba(0, 0, 0, 0.4) inset, 1px 0 rgba(0, 0, 0, 0.3) inset,
> +              0 1px rgba(255, 255, 255, 0.5);
> +  text-shadow: 0 1px rgba(0, 0, 0, 0.4) !important;

I know we don't have any more checked toolbar buttons, but maybe these styles should instead be applied to .cal-toolbarbutton-1[checked="true"] instead?

Also, was it on purpose that this style is mac only?
Attachment #601522 - Flags: review?(philipp)
Attachment #601522 - Flags: review+
Attachment #601522 - Flags: approval-calendar-beta+
Attachment #601522 - Flags: approval-calendar-aurora+
I'll change the checked rule to the more global one.

It was on purpose only on Mac because the other systems have good looking checked states. Mac's toolbox rules have only a gray background which fills the whole toolbar height.
Pushed to comm-central:<http://hg.mozilla.org/comm-central/rev/ec70da576491>
comm-aurora: <http://hg.mozilla.org/releases/comm-aurora/rev/be64885ac405>
and comm-beta: <http://hg.mozilla.org/releases/comm-beta/rev/566537137d0c>
Status: ASSIGNED → RESOLVED
Closed: 10 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3
Comment on attachment 601522 [details] [diff] [review]
Fix which should better work with SM

A bit late, anyway, it's a f+ because in my opinion that button can be used often.

Generally, I'm not a big fan of a toolbar for calendar mode with only buttons related to calendar actions, because those buttons allow actions that can done with a minimum work on the UI (e.g. "go to today" button is already present in the view, "New event" can be done with a double click, "Print" is used rarely, etc.). Instead for me would be better a toolbar with the "Get Mail" and "Address Book" buttons that are also available in calendar mode.

I liked the idea of the TB' search button (comment #6) because it already does the same action in mail mode and now (TB 12) the button is always present in the view but is disabled in calendar mode. Moreover it would allow to keep the find button even without the calendar toolbar (when will be possible disable it like is already possible with the mail toolbar).
Attachment #601522 - Flags: feedback?(bv1578) → feedback+
I wouldn't oppose to adding mail specific buttons to the calendar toolbar. Regarding the get mail button, I think ideally Thunderbird should change their button to Synchronize so we can use the same button to refresh multiple things.

Addressbook also makes sense. IIRC then the go to today and print button is not in the default set, so I do think we should keep them for users that would like to keep it.

I'd suggest to open new follow-up bug(s) and discuss the UI changes with andreasn or bwinton.

Thanks for your feedback!
Pushed a fix for comm-beta, menuOverlay.dtd was missing:

releases/comm-beta changeset c188d94b4df1
You need to log in before you can comment on or make changes to this bug.