Closed Bug 548646 Opened 10 years ago Closed 10 years ago
Permission manager getter in Services
.jsm should be more descriptive
Unless you already know what it is, "Services.pm" or "Services.pm.add()" isn't very descriptive. There's already a Services.prefs (for the pref service), so renaming .pm to .perms would make things both more readable and consistent.
Attachment #428986 - Flags: review?(gavin.sharp)
Comment on attachment 428986 [details] [diff] [review] Patch v.1 >diff --git a/toolkit/content/tests/browser/browser_Services.js b/toolkit/content/tests/browser/browser_Services.js >+ ok(Services.perms instanceof Ci.nsIPermissionManager, "Services.pm is an nsIPermissionManager"); Fix the test message too?
Attachment #428986 - Flags: review?(gavin.sharp) → review+
Assignee: nobody → dolske
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a2
You need to log in before you can comment on or make changes to this bug.