Javascript : MarqueeObject.start() is not a function with Firefox 3.6

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: thierry.l24, Unassigned)

Tracking

(Depends on: 1 bug, {regression})

1.9.2 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6

On the sample page, when clicking a link on map or list, a new page is loaded by thickbox in an iframe. In this page, there's a marquee with pictures.
With Firefox, the marquee do not start directly because of the display: none of the iframe before the click is made - that's a standard behavior for a long time -
In order to start the marquee, once the page is loaded, there's a little script that is starting the marquee after a short delay.
It works fine with Firefox 3.5.8 and below, but with Firefox 3.6, there's a message MarqueeObject.start() is not a function, and the marquee don't start. 

Reproducible: Always

Steps to Reproduce:
1.click on a link on the map
2.the marquee do not start
3.try with Firefox 3.5.8, it works
Actual Results:  
The marquee do not start

Expected Results:  
The marquee should start
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch

Comment 1

9 years ago
Works for me, have you tested in firefox safe mode?
(Reporter)

Comment 2

9 years ago
yes, same result . 
Are you sure, you're seeing the picture scrolling in the iframe with 3.6 version ?
Curiously, the message 'obj.start is not a function' doesn't appear everytime in the error console with or without firebug.
As I have some problem with firebug 1.5.2 under 3.6 too (fine with 1.5.0), I will reinstall firefox to check if something is broken.
(Reporter)

Comment 3

9 years ago
Reinstall has been done - No plugins - No extensions - same result.
I see the problem, this would probably fixed with the patch for bug 235564. In the meantime, if you really want this working, you could try calling the init() function yourself, after onload. I think that would fix it.
Depends on: 235564
(Reporter)

Comment 5

9 years ago
Well, yes and no, I noticed that firefox doesn't launch a marquee when a display:none state become display:block but, the script I used was ok on Firefox 3.5.8 (and before) and not on Firefox 3.6. 
I don't see why, if I reload the Frame, marquee's fine.
I tried stop / start, _doMove, _fireEvent, truespeed or not ... nothing happens.
I tried init too, I only get a blank marquee.

Problem is that release 3.6 is now available, and I have some calls from customers : "marquee is not animated anymore, why ?"

I'm not an expert on jquery, may be is it possible to launch marquee thru this way, but anyway, it is not working as before 3.6
(Reporter)

Comment 6

9 years ago
I finally decide to use a location.reload(false) in order to start the marquee, so it works fine now, but I don't like it because of the reload.
I let the old script with the bug described upper on number 1, if someone want to test it, he may use it.
Remember that the problem is : the script works fine with Firefox < 3.6, but not with Firefox 3.6.
Yeah, the fact that it appears to be a regression is not good. It might be good to get a regression range and testcase here.
Keywords: regression, regressionwindow-wanted, testcase-wanted
(Reporter)

Comment 8

9 years ago
I changed the address of the page,
the new page is quite simple, and is detached from the website.
The first page is 
http://www.accueil-paysan-dordogne.com/test1.html
with the iframe and thickbox
The second page is
http://www.accueil-paysan-dordogne.com/test2.html
with the marquee.
I think it's easier to test.
I checked it, the problem is the same, it works with FF3.5.8, not with FF3.6.
For Test1 i can confirm the Issue testing against Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 ID:20100824153629 - Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.12) Gecko/20100824 Firefox/3.5.12 ID:20100824110549 is okay.

Regression Range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a1c1a8bfd19e&tochange=c989bb1f272d
what points to Bug 166591

Both Tests are working fine on Trunk with html5.enable;false only, but that might be expected.
Blocks: 166591
Component: General → Layout
Keywords: regressionwindow-wanted, testcase-wanted
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: x86 → All
Version: 3.6 Branch → 1.9.2 Branch
Firefox: 45.0.1, Build ID: 20160315153207
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Hi Thierry,

I have tested this issue on the latest Firefox (45.0.1) release, latest Nightly (48.a01 - Build ID: 20160322030417) build bud I could not reproduce it. I have tested this issue using the provided URLs from comment 8, but everything work as expected. Can you please provide more details about how to reproduce this issue? 

Also, is this still reproducible on your end ? If yes, can you please retest this using latest Firefox release and latest Nightly build (https://nightly.mozilla.org/)and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E). 

Thanks,
Cosmin.
Flags: needinfo?(thierry.l24)
Considering the fact that I cannot reproduce this and the fact that the reporter did not answered to my request until now, I will mark this as Resolved-Worksforme.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks,
Cosmin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(thierry.l24)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.